summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 05744708e551..b75de101be51 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,13 +8,14 @@ pkgdesc='Gateway6 client implementation of the Tunnel Setup Protocol from Hexago
url="http://go6.net/4105/download.asp"
depends=('openssl')
source=('http://go6.net/4105/file.asp?file_id=150' 'debian.patch' 'fix_missing_headers.patch' 'tspc')
-md5sums=('5c5205dc58e82454a5d55a3efb4bf786' 'deb1833e122c6ccbc02e04eeec9d200a' 'ea98bbce3ba371e45db7b9535e352363' '2694da554049281765d05104c6f3dfea')
+md5sums=('5c5205dc58e82454a5d55a3efb4bf786' 'deb1833e122c6ccbc02e04eeec9d200a' 'ea98bbce3ba371e45db7b9535e352363' '90531e3b43afcbec63269e2a990b74c3')
arch=(i686 x86_64)
license=('BSD')
build() {
cd $startdir/src/tspc-advanced
patch -p1 < $startdir/src/debian.patch
+ patch -p1 < setup.diff
cd $startdir/src
patch -p1 < $startdir/src/fix_missing_headers.patch
@@ -27,10 +28,11 @@ build() {
sed -i "s/gw6c/tspc/g" \
$startdir/pkg/usr/man/{man5/tspc.conf.5,/man8/tspc.conf.8}
- install -D template/linux.sh -m 0755 $startdir/pkg/etc/tspc/linux.sh
+ install -D template/linux.sh -m 0755 $startdir/pkg/etc/tsp/linux.sh
+ sed -i -e "s/init\.d/rc.d/g" $startdir/pkg/etc/tsp/linux.sh
install -D bin/gw6c.conf.sample -m 0600 \
- $startdir/pkg/etc/tspc/tspc.conf
- sed -i -e "s#^gw6_dir=.*#gw6_dir=/usr/sbin\ntsp_dir=/etc/tspc#g" \
- $startdir/pkg/etc/tspc/tspc.conf
+ $startdir/pkg/etc/tsp/tspc.conf
+ sed -i -e "s#^gw6_dir=.*#gw6_dir=/usr/sbin\ntsp_dir=/etc/tsp#g" \
+ $startdir/pkg/etc/tsp/tspc.conf
install -D $startdir/tspc -m 0755 $startdir/pkg/etc/rc.d/tspc
}