summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 8 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 972f16a11670..a8c74ffe63a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,19 @@
-# Maintainer: Jonathan Liu <net147@gmail.com>
pkgname=ttcp
-pkgver=20100419
-pkgrel=1
+pkgver=20071201
+pkgrel=2
pkgdesc="TCP benchmarking tool"
arch=('i686' 'x86_64')
-url="http://www.pcausa.com/Utilities/pcattcp.htm"
license=('custom:Public Domain')
depends=('glibc')
-source=("http://www.pcausa.com/Utilities/pcattcp/LinuxTTCP.zip"
- "LICENSE")
-md5sums=('5b4707910c24fec212609f862bc53749'
- 'd8d09df3d799fec1b0b8a080948ffbb2')
-
+makedepends=('gcc')
+source=("http://www.netcore.fi/pekkas/linux/ipv6/ttcp.c")
build() {
- cd "${srcdir}/LinuxTTCP"
- [ -f makefile ] && rm -f makefile
- make ttcp
+ cd "${srcdir}"
+ gcc ttcp.c -o ttcp
}
package() {
- cd "$srcdir/LinuxTTCP"
+ cd "${srcdir}"
install -D -m755 ttcp "${pkgdir}/usr/bin/ttcp"
- install -D -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/ttcp/LICENSE"
}
-
-# vim:set ts=2 sw=2 et:
+md5sums=('2f6ffb3e9132f4815c3ade3bd1dba99b')