summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 11 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5d0af0f07c52..b047f3dfbb53 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,23 @@
# Maintainer: LightDot <lightdot -a-t- g m a i l>
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
# Contributor: samæ <samæ at marvid dot fr>
_fnt_name=knewave
pkgname=ttf-$_fnt_name
pkgver=20160215
-pkgrel=2
-pkgdesc="A bold, painted face font for the rocker within."
+_sha=f335d5ff1f12e4acf97d4208e1c37b4d386e57fb
+pkgrel=3
+pkgdesc='A bold, painted face font for the rocker within'
arch=('any')
url="http://theleagueofmoveabletype.com/$_fnt_name"
-license=('custom:OFL')
+license=('OFL')
groups=('lmt-fonts')
-depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils')
-source=("$pkgname-$pkgver.zip::https://github.com/theleagueof/$_fnt_name/archive/master.zip")
-md5sums=('ec880e36c11c0a16b06be6cd5884e3b8')
+source=("$pkgname-$pkgver.zip::https://github.com/theleagueof/$_fnt_name/archive/$_sha.zip")
+sha256sums=('e5fc9f85d929f2ddb678a55786a65cd63435d75e9f146e09aff07ca68eda52d9')
package() {
- install -d "$pkgdir"/usr/share/fonts/OTF
- install -d "$pkgdir"/usr/share/fonts/TTF
- install -Dm644 "$srcdir/$_fnt_name"-master/*.otf "$pkgdir"/usr/share/fonts/OTF/
- install -Dm644 "$srcdir/$_fnt_name"-master/*.ttf "$pkgdir"/usr/share/fonts/TTF/
-
- install -Dm644 "$srcdir/$_fnt_name"-master/Open\ Font\ License.markdown "$pkgdir/usr/share/licenses/$pkgname"/OFL.txt
+ cd "$_fnt_name-$_sha"
+ install -Dm644 -t "$pkgdir/usr/share/fonts/TTF/" *.ttf
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" Open\ Font\ License*.markdown
+ install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname/" readme.markdown
}