summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 16 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 45afd64f5f58..067b054eebd4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,26 @@
# Maintainer: LightDot <lightdot -a-t- g m a i l>
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
# Contributor: samæ <samæ at marvid dot fr>
_fnt_name=league-gothic
-pkgname=ttf-${_fnt_name}
+pkgname=ttf-$_fnt_name
pkgver=20160215
-pkgrel=2
-pkgdesc="League Gothic is a revival of an old classic, and one of our favorite typefaces, Alternate Gothic #1"
+# 20140319
+_sha=e6dce2137410648b2229d5d4717de8c1cd5f9b97
+pkgrel=4
+pkgdesc='A revival of an old classic, Alternate Gothic #1'
arch=('any')
-url="http://theleagueofmoveabletype.com/${_fnt_name}"
-license=('custom:OFL')
+url="https://theleagueofmoveabletype.com/$_fnt_name"
+license=('OFL')
groups=('lmt-fonts')
-depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils')
-conflicts=('otf-league-gothic')
-source=("$pkgname-$pkgver.zip::https://github.com/theleagueof/${_fnt_name}/archive/master.zip")
-md5sums=('e19525cac31d325b4604d01e36c9fd6c')
+provides=('league-gothic-font')
+conflicts=("otf-$_fnt_name")
+source=("$pkgname-$pkgver.zip::https://github.com/theleagueof/$_fnt_name/archive/$_sha.zip")
+sha256sums=('f4cc4f754568c4d2b70c3b52a6663677656ee88277901efcdf079b40e8158ab1')
package() {
- install -Dm644 ${srcdir}/${_fnt_name}-master/LeagueGothic-CondensedItalic.otf ${pkgdir}/usr/share/fonts/OTF/LeagueGothic-CondensedItalic.otf
- install -Dm644 ${srcdir}/${_fnt_name}-master/LeagueGothic-CondensedRegular.otf ${pkgdir}/usr/share/fonts/OTF/LeagueGothic-CondensedRegular.otf
- install -Dm644 ${srcdir}/${_fnt_name}-master/LeagueGothic-Italic.otf ${pkgdir}/usr/share/fonts/OTF/LeagueGothic-Italic.otf
- install -Dm644 ${srcdir}/${_fnt_name}-master/LeagueGothic-Regular.otf ${pkgdir}/usr/share/fonts/OTF/LeagueGothic-Regular.otf
-
- install -Dm644 ${srcdir}/${_fnt_name}-master/webfonts/leaguegothic-condensed-italic-webfont.ttf ${pkgdir}/usr/share/fonts/TTF/LeagueGothic-CondensedItalic.ttf
- install -Dm644 ${srcdir}/${_fnt_name}-master/webfonts/leaguegothic-condensed-regular-webfont.ttf ${pkgdir}/usr/share/fonts/TTF/LeagueGothic-CondensedRegular.ttf
- install -Dm644 ${srcdir}/${_fnt_name}-master/webfonts/leaguegothic-italic-webfont.ttf ${pkgdir}/usr/share/fonts/TTF/LeagueGothic-Italic.ttf
- install -Dm644 ${srcdir}/${_fnt_name}-master/webfonts/leaguegothic-regular-webfont.ttf ${pkgdir}/usr/share/fonts/TTF/LeagueGothic-Regular.ttf
-
- install -Dm644 ${srcdir}/${_fnt_name}-master/Open\ Font\ License.markdown ${pkgdir}/usr/share/licenses/${pkgname}/OFL.txt
+ cd "$_fnt_name-$_sha"
+ install -Dm644 -t "$pkgdir/usr/share/fonts/TTF/" webfonts/*.ttf
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" Open\ Font\ License*.markdown
+ install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname/" readme.markdown
}