summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b79198d81795
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: samæ <samæ at marvid dot fr>
+
+_fnt_name=league-gothic
+pkgname=ttf-${_fnt_name}
+pkgver=20160215
+pkgrel=1
+pkgdesc="League Gothic is a revival of an old classic, and one of our favorite typefaces, Alternate Gothic #1"
+arch=('any')
+url="http://theleagueofmoveabletype.com/${_fnt_name}"
+license=('custom:OFL')
+groups=('lmt-fonts')
+depends=('fontconfig' 'xorg-font-utils')
+replaces=('otf-league-gothic')
+source=("https://github.com/theleagueof/${_fnt_name}/archive/master.zip")
+install=${pkgname}.install
+md5sums=('e19525cac31d325b4604d01e36c9fd6c')
+
+package() {
+ install -Dm644 ${srcdir}/${_fnt_name}-master/LeagueGothic-CondensedItalic.otf ${pkgdir}/usr/share/fonts/OTF/LeagueGothic-CondensedItalic.otf
+ install -Dm644 ${srcdir}/${_fnt_name}-master/LeagueGothic-CondensedRegular.otf ${pkgdir}/usr/share/fonts/OTF/LeagueGothic-CondensedRegular.otf
+ install -Dm644 ${srcdir}/${_fnt_name}-master/LeagueGothic-Italic.otf ${pkgdir}/usr/share/fonts/OTF/LeagueGothic-Italic.otf
+ install -Dm644 ${srcdir}/${_fnt_name}-master/LeagueGothic-Regular.otf ${pkgdir}/usr/share/fonts/OTF/LeagueGothic-Regular.otf
+
+ install -Dm644 ${srcdir}/${_fnt_name}-master/webfonts/leaguegothic-condensed-italic-webfont.ttf ${pkgdir}/usr/share/fonts/TTF/LeagueGothic-CondensedItalic.ttf
+ install -Dm644 ${srcdir}/${_fnt_name}-master/webfonts/leaguegothic-condensed-regular-webfont.ttf ${pkgdir}/usr/share/fonts/TTF/LeagueGothic-CondensedRegular.ttf
+ install -Dm644 ${srcdir}/${_fnt_name}-master/webfonts/leaguegothic-italic-webfont.ttf ${pkgdir}/usr/share/fonts/TTF/LeagueGothic-Italic.ttf
+ install -Dm644 ${srcdir}/${_fnt_name}-master/webfonts/leaguegothic-regular-webfont.ttf ${pkgdir}/usr/share/fonts/TTF/LeagueGothic-Regular.ttf
+
+ install -Dm644 ${srcdir}/${_fnt_name}-master/Open\ Font\ License.markdown ${pkgdir}/usr/share/licenses/${pkgname}/OFL.txt
+}
+