summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 30a4858cbcf4..94cf787b71ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,26 @@
# Maintainer: zoorat <zoorat [at] protonmail [dot] com>
+# Contributor: Mike Swanson <mikeonthecomputer@gmail.com>
pkgname=ttf-mononoki
pkgver=1.6
-pkgrel=1
+pkgrel=2
pkgdesc="Monospace font for programmers, successor of monoOne"
arch=('any')
url="https://madmalik.github.io/mononoki/"
license=('custom:OFL')
-depends=('fontconfig')
-makedepends=()
-conflicts=("ttf-mononoki-git")
provides=("ttf-mononoki")
-options=(emptydirs)
+conflicts=("ttf-mononoki-git")
+options=(strip emptydirs zipman)
+changelog="changelog.md"
-source=("https://github.com/madmalik/mononoki/archive/$pkgver.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/madmalik/mononoki/archive/$pkgver.tar.gz")
b2sums=('584bf6d1f319fd15b30fcc2dc1f3c58e76105b1ca3cd6a02982e80c2df645b9861878dbfa0eb52768c3dfd2900ff30b59a3fad7e77a2785dc08087668cf54931')
package() {
- cd mononoki-$pkgver
- install -dm755 "$pkgdir/usr/share/fonts/ttf-mononoki"
- install -m644 -t "$pkgdir/usr/share/fonts/ttf-mononoki" export/*.ttf
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd mononoki-$pkgver || exit
+ install -dm755 "$pkgdir/usr/share/fonts/ttf-mononoki"
+ install -m644 -t "$pkgdir/usr/share/fonts/ttf-mononoki" export/*.ttf
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}