summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 661cb5ae76e6..34c225bd99a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,24 @@
# Maintainer: George Rawlinson <george@rawlinson.net.nz>
# Contributor: mock
+
pkgname=ttf-nishiki-teki
-pkgver=3.65p
+pkgver=3.65s
pkgrel=1
pkgdesc='Unicode-based font inspired by a free shell of Ukagaka called “Nishiki”'
arch=('any')
url='http://hwm3.gyao.ne.jp/shiroi-niwatori/nishiki-teki.htm'
license=('custom')
-source=("$pkgname-$pkgver.zip::http://hwm3.gyao.ne.jp/shiroi-niwatori/nishiki-teki.zip"
+source=("$pkgname.zip::http://hwm3.gyao.ne.jp/shiroi-niwatori/nishiki-teki.zip"
"LICENSE")
-sha512sums=('183b2286eeda0be92bd24bcc75d679e885a138af16726fb46c01d50167ed7be327ebdc041f9de09b62098e2cb9726dff74e6026e5edff09abae8a183d7024e9d'
+sha512sums=('SKIP'
'f6138f41a7eade900bcda1a5be608cbb4a8205ce53c6d175d6ae13693ff34b8e2cdc42f9dd4ae49b7285a5f09c1fb4f077ad872361abb8303c1589acf5958436')
+pkgver() {
+ cd nishiki-teki_*
+ grep -Eo 'Version [[:digit:]]\.[[:digit:]]*[[:alpha:]]?' nishiki-teki.htm | head -n 1 | sed 's/Version //'
+}
+
package() {
- # this feels like a hacky workaround
cd nishiki-teki_*
# install font