summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 22 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e1f2fa13e468..61e8e8252174 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,29 @@
-# Maintainer: Brandon Giesing <brandon@giesing.cf>
-
+# Maintainer: Markus Weimar <mail@markusweimar.de>
+# Contributor: Brandon Giesing <brandon@giesing.cf>
pkgname=ttf-roboto-slab
-pkgver=r4f5374de05
+pkgver=1.100263
pkgrel=1
-pkgdesc='Serif Roboto font from Google Keep'
+epoch=3
+depends=('fontconfig' 'xorg-font-utils')
+pkgdesc='Roboto Slab is a slab serif addition to the Roboto type family.'
arch=('any')
-license=('APACHE')
url='https://www.google.com/fonts/specimen/Roboto+Slab'
-depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils')
-makedepends=('subversion')
-source=('svn+https://github.com/google/fonts/trunk/apache/robotoslab')
-md5sums=('SKIP')
-install=$pkgname.install
-
-pkgver() {
- printf "r$(svn propget git-commit --revprop -r HEAD https://github.com/google/fonts/trunk/apache/robotoslab | cut -c -10)"
-}
+license=('Apache')
+source=('https://raw.githubusercontent.com/google/fonts/master/apache/robotoslab/LICENSE.txt'
+ 'https://raw.githubusercontent.com/google/fonts/master/apache/robotoslab/RobotoSlab-Bold.ttf'
+ 'https://raw.githubusercontent.com/google/fonts/master/apache/robotoslab/RobotoSlab-Light.ttf'
+ 'https://raw.githubusercontent.com/google/fonts/master/apache/robotoslab/RobotoSlab-Regular.ttf'
+ 'https://raw.githubusercontent.com/google/fonts/master/apache/robotoslab/RobotoSlab-Thin.ttf')
+install=${pkgname}.install
+sha256sums=('cfc7749b96f63bd31c3c42b5c471bf756814053e847c10f3eb003417bc523d30'
+ 'ba12d2eab1fa765b6b05398fa7e047dd76293f0c051ce57a8f7b0c591c14d42b'
+ '153bf5b428d5cd0b27a63f9a36941cd7d6c7523a7afd59c76a12f798e4c33127'
+ '13aa5f54c6f2fa2e388fe0e675cdbcc6a81f6270a8bf9c03a5df8af9cb022810'
+ '4e2f26097538925162cad2a3e6051f659b9895386559a1890a4664d8e9a9a0c1')
package() {
- install -d $pkgdir/usr/share/licenses/$pkgname/
- install -m644 $srcdir/robotoslab/LICENSE.txt $pkgdir/usr/share/licenses/$pkgname/
- install -d $pkgdir/usr/share/fonts/TTF/
- install -m644 robotoslab/*.ttf $pkgdir/usr/share/fonts/TTF/
+ cd ${srcdir}
+ install -d ${pkgdir}/usr/share/fonts/TTF/
+ install -m644 *.ttf ${pkgdir}/usr/share/fonts/TTF/
+ install -D -m644 LICENSE.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
}
-
-