summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e58c9b0a2f93
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+_pkgname=awami-nastaliq
+pkgname=ttf-sil-$_pkgname
+_fname=AwamiNastaliq
+pkgver=2.000
+pkgrel=1
+pkgdesc='Designed for Arabic-based writing systems using the Nastaliq-style'
+arch=('any')
+url="https://software.sil.org/${_pkgname/-*}"
+license=('custom:OFL')
+depends=('fontconfig' 'xorg-font-utils')
+source=("http://software.sil.org/downloads/r/${_pkgname/-*}/$_fname-$pkgver.zip")
+sha256sums=('caa282f45361b6f661a9aeccb039f6264b0be2dfd631f5e83c6b8ee940b5794a')
+
+package() {
+ cd "$_fname-$pkgver"
+ find -type f -iname "$_fname*.ttf" -execdir \
+ install -Dm644 {} -t "$pkgdir/usr/share/fonts/TTF" \;
+ install -Dm644 OFL.txt -t "$pkgdir/usr/share/licenses/$pkgname"
+}