summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 17 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 403f9ca1d26a..39bd2d16238b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,23 @@
-# Maintainer: Caleb Maclennan <caleb@alerque.com>
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
# Contributor: bslackr <brendan at vastactive dot com>
# Contributor: Firmicus <firmicus āt gmx dōt net>
-pkgname=ttf-sil-lateef
-_fname=LateefGR
-pkgver=1.200
-pkgrel=3
-pkgdesc='OpenType Arabic font from SIL'
-arch=('any')
-url='https://software.sil.org/lateef/'
-license=('custom:OFL')
-depends=('fontconfig' 'xorg-font-utils')
-conflicts=('ttf-sil-arabic' 'ttf-sil-fonts')
-source=("http://software.sil.org/downloads/r/lateef/${_fname}-${pkgver}.zip")
-sha256sums=('ef6c6b4b4cb8d8502c78efc43cb99d29f391e6cb9eba1b133a661ffda3ddc7e1')
+_pkgname=lateef
+pkgname=ttf-sil-$_pkgname
+_fname=${_pkgname^}
+pkgver=4.200
+pkgrel=1
+pkgdesc='An Arabic script font for Sindhi and other languages of southern Asia'
+arch=(any)
+url="https://software.sil.org/$_pkgname"
+license=(OFL-1.1-RFN)
+_archive="$_fname-$pkgver"
+source=("https://software.sil.org/downloads/r/$_pkgname/$_archive.zip")
+sha256sums=('aab697ad2bcc82baa72a7083b2ab1d0a503bc74806d49c54ffb5bcdaab58e36f')
package() {
- cd "${_fname}-${pkgver}"
- install -Dm644 ${_fname}-Regular.ttf ${pkgdir}/usr/share/fonts/TTF/${_fname}-Regular.ttf
- install -Dm644 OFL.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ cd "$_archive"
+ install -Dm0644 -t "$pkgdir/usr/share/fonts/TTF/" *.ttf
+ install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" OFL.txt
+ install -Dm0644 -t "$pkgdir/usr/share/doc/$pkgname/" README.txt FONTLOG.txt documentation/pdf/*
}