summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 19 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f07d03ba36f2..5abee7649607 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,39 @@
# Maintainer: Mario Finelli <mario at finel dot li>
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
# Contributor: Arthur Titeica <arthur dot titeica at gmail dot com>
pkgname=ttfautohint
pkgver=1.8.3
-pkgrel=1
-pkgdesc="Provides automated hinting process for web fonts."
+pkgrel=2
+pkgdesc='Provides automated hinting process for web fonts'
arch=('i686' 'x86_64')
-url="http://www.freetype.org/ttfautohint/"
+url="http://www.freetype.org/$pkgname"
license=('GPL' 'custom')
-depends=('freetype2' 'qt5-base' 'noto-fonts' 'noto-fonts-alpha')
-optdepends=('texlive-bin: generate docs'
- 'pandoc: generate docs'
- 'ghc: pandoc filter')
+depends=('freetype2' 'harfbuzz' 'qt5-base')
source=(https://download.savannah.gnu.org/releases/freetype/$pkgname-$pkgver.tar.gz{,.sig})
sha256sums=('87bb4932571ad57536a7cc20b31fd15bc68cb5429977eb43d903fa61617cf87e'
'SKIP')
validpgpkeys=('58E0C111E39F5408C5D3EC76C1A60EACE707FDA5')
build() {
- cd "$srcdir/$pkgname-$pkgver"
- export QMAKE='/usr/bin/qmake'
- export MOC='/usr/bin/moc'
- export UIC='/usr/bin/uic'
- export RCC='/usr/bin/rcc'
- export TTFONTS='/usr/share/fonts/noto'
- ./configure --prefix=/usr --with-qt=/usr/lib/qt \
- --with-freetype-config="pkg-config freetype2"
- make
+ cd "$pkgname-$pkgver"
+ ./configure \
+ --prefix=/usr \
+ --without-doc \
+ --with-qt=/usr/lib/qt \
+ --with-freetype-config="pkg-config freetype2"
+ make
}
check() {
- cd "$srcdir/$pkgname-$pkgver"
- make -k check
+ cd "$pkgname-$pkgver"
+ make -k check
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- make DESTDIR="$pkgdir/" install
-
- install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
- install -Dm644 FTL.TXT "${pkgdir}/usr/share/licenses/${pkgname}/FTL.TXT"
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" COPYING FTL.TXT
+ install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname/" "doc/$pkgname.pdf"
+ install -Dm644 -t "$pkgdir/usr/share/man/man1/" "frontend/$pkgname"{,GUI}.1
}