summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5b8053ef5488..5abb3e76e045 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
pkgname=ttfautohint
pkgver=1.6
-pkgrel=1
+pkgrel=2
pkgdesc="Provides automated hinting process for web fonts."
arch=('i686' 'x86_64')
url="http://www.freetype.org/ttfautohint/"
license=('GPL' 'custom')
-depends=('freetype2' 'qt4')
+depends=('freetype2' 'qt5-base')
optdepends=('texlive-bin: generate docs'
'pandoc: generate docs'
'ghc: pandoc filter')
@@ -19,13 +19,11 @@ validpgpkeys=('58E0C111E39F5408C5D3EC76C1A60EACE707FDA5')
build() {
cd "$srcdir/$pkgname-$pkgver"
- export QMAKE='/usr/bin/qmake-qt4'
- export MOC='/usr/bin/moc-qt4'
- export UIC='/usr/bin/uic-qt4'
- export RCC='/usr/bin/rcc-qt4'
- # export QTDIR='/usr/lib/qt4'
- # CFLAGS="-I/usr/include/qt4"
- ./configure --prefix=/usr --with-qt=/usr/lib/qt4
+ export QMAKE='/usr/bin/qmake'
+ export MOC='/usr/bin/moc'
+ export UIC='/usr/bin/uic'
+ export RCC='/usr/bin/rcc'
+ ./configure --prefix=/usr --with-qt=/usr/lib/qt
make
}