summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..77b3ede1e12f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Jake Howard <git+aur@theorangeone.net>
+pkgname=tupload
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Capture screenshots and upload them using rsync"
+arch=('any')
+url="https://github.com/RealOrangeOne/tupload"
+license=('unknown')
+depends=('python-setuptools' 'rsync' 'gnome-screenshot')
+makedepends=('python-pip')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/RealOrangeOne/tupload/archive/$pkgver.tar.gz")
+sha512sums=('e18fe97b985acc357b263f733cc5363f46132f56354df20a4868734df847d1cb4af385dd0dd85cf0e2f92a0b1549e4a3f47187cd8a3405f6787594e6c3fff0b9')
+
+package() {
+ cd $pkgname-$pkgver
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 tupload/config.json "$pkgdir"/etc/.upload
+}