summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 64bc70604508..f0b62c7e6b6d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,17 @@
# Maintainer: Dennis Stengele <d.stengele (at) derintendant (dot) de>
pkgname=tuptime
-pkgver=3.3.0
-pkgrel=2
+pkgver=3.3.3
+pkgrel=1
pkgdesc="Report the historical and statistical running time of system"
arch=('any')
url="https://github.com/rfrail3/tuptime"
license=('GPL')
groups=()
depends=(
- 'python2'
- 'cron'
+ 'python'
)
makedepends=()
-optdepends=()
+optdepends=('cron')
provides=()
conflicts=()
replaces=()
@@ -20,14 +19,14 @@ backup=()
options=()
install=
changelog=
-source=("$pkgname-$pkgver-$pkgrel.tar.gz::https://github.com/rfrail3/tuptime/archive/${pkgver}-${pkgrel}.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/rfrail3/tuptime/archive/${pkgver}.tar.gz")
noextract=()
-sha256sums=('0c48cea06eba819c9c0d9818c59390d16feb8dc3e8d19d2c34e9b157f1fa02ae')
+sha256sums=('be4dc5207859eeb0e6cfef206db5dd62b553e69ac0641c7203278cdd61c95bea')
package() {
- cd "$srcdir/$pkgname-${pkgver}-${pkgrel}"
+ cd "$srcdir/$pkgname-${pkgver}"
install -Dm755 "src/tuptime" "$pkgdir/usr/bin/tuptime"
install -Dm644 "src/systemd/tuptime.service" "$pkgdir/usr/lib/systemd/system/tuptime.service"
- install -Dm644 "src/cron.d/tuptime" "$pkgdir/etc/cron.d/tuptime"
+ install -Dm644 "src/systemd/tuptime.timer" "$pkgdir/usr/lib/systemd/system/tuptime.timer"
}