summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..80bef8779439
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: oi_wtf <brainpower at mailbox dot org>
+
+pkgname=tuxedo-touchpad-switch
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="A Linux userspace driver to enable and disable the touchpads on TongFang/Uniwill laptops"
+url="https://github.com/tuxedocomputers/tuxedo-touchpad-switch"
+arch=(x86_64)
+license=(GPL3)
+
+depends=("glib2")
+makedepends=("git" "cmake" "ninja")
+
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+
+#https://github.com/tuxedocomputers/tuxedo-touchpad-switch/archive/v$pkgver/${pkgname}-${pkgver}.tar.gz
+source=(
+ git+https://github.com/tuxedocomputers/tuxedo-touchpad-switch.git#commit=3f90c9c6c1e51f6d8538877d2f15677ce39b167b
+)
+sha256sums=(SKIP)
+#sha256sums=('dd4fa6871735fed3e094f177f0a2d0861fd3411ef4e6fbf1fbba5405a01ae219')
+
+build() {
+ cd "${pkgname}"
+
+ cmake -B builddir -G Ninja \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo
+
+ ninja -C builddir
+}
+
+package() {
+ cd "${pkgname}"
+
+ DESTDIR="${pkgdir}" ninja -C builddir install
+}