summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index be979cc5bece..a980fc75570b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: gbr <gbr@protonmail.com>
_pkgname=twittuh
pkgname=twittuh-git
-pkgver=r89.ef45111
+pkgver=r100.e1bd11b
pkgrel=1
pkgdesc='Small Go program to make RSS/ATOM/JSON feeds from Twitter timelines'
arch=('x86_64')
url='https://github.com/derat/twittuh'
license=('BSD')
depends=('chromium')
-makedepends=('go')
+makedepends=('git' 'go')
source=("$_pkgname::git+https://github.com/derat/twittuh.git#branch=master")
sha256sums=('SKIP')
@@ -18,7 +18,7 @@ pkgver() {
}
build() {
- cd "$srcdir/$_pkgname"
+ cd "$_pkgname"
go build \
-o "$_pkgname" \
-trimpath \
@@ -30,12 +30,12 @@ build() {
}
check() {
- cd "$srcdir/$_pkgname"
+ cd "$_pkgname"
go test -v ./...
}
package() {
- cd "$srcdir/$_pkgname"
+ cd "$_pkgname"
install -Dm755 $_pkgname "$pkgdir"/usr/bin/$_pkgname
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
}