summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 6 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e714a20f30b5..c6f3957e7b47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Jan Max Meyer <codepilot@phorward.info>
-_txt2tags=txt2tags
-pkgname=$_txt2tags-git
+_pkgname=txt2tags
+pkgname=$_pkgname-git
pkgver=2.6.99
pkgrel=1
epoch=
@@ -8,26 +8,22 @@ pkgdesc="A text formatting and conversion tool - Development version"
arch=('any')
url="http://www.txt2tags.org"
license=('GPL')
-conflicts=("$_txt2tags")
+conflicts=("$_pkgname")
depends=('python2')
optdepends=('ruby: for running t2tmake.rb'
'sh: for running html-update.sh'
'vim: for using the vim-files')
-makedepends=('gettext', 'git')
+makedepends=('git')
source=("git://github.com/txt2tags/txt2tags.git")
md5sums=('SKIP')
-build() {
- cd "$pkgname-$pkgver"
-}
-
check() {
- cd "$pkgname-$pkgver"
+ cd "$srcdir/$_pkgname"
python2 setup.py check
}
package() {
- cd "$pkgname-$pkgver"
+ cd "$srcdir/$_pkgname"
python2 setup.py install --root="$pkgdir/"
}