summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..42f8f31c48cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Luis Pérez <luis dot perez at protonmail dot com>
+pkgname=typioca
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="Tapioca (/ˌtæpiˈoʊkə/) is a starch extracted from the storage roots of the cassava plant. Pearl tapioca is a common ingredient in Asian desserts...and sweet drinks such as bubble tea."
+arch=(any)
+url="https://github.com/bloznelis/typioca"
+license=('MIT')
+makedepends=('go' 'make')
+provides=(typioca)
+conflicts=()
+source=("https://github.com/bloznelis/typioca/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('fa28239cd5fdb11ea0c2aba32cff767a7ce46f18d769f821797c6942ae2b9052')
+
+build() {
+ cd "$pkgname-$pkgver"
+ make build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 "${srcdir}/$pkgname-$pkgver/execs/typioca" "${pkgdir}/usr/bin/typioca"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}