summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..791734edd20f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
+
+pkgname=typography
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Tool for working with the GNOME typography design guidelines"
+arch=('any')
+url="https://gitlab.gnome.org/World/design/typography"
+license=('GPL3')
+depends=('gtk4')
+makedepends=('git' 'meson')
+source=("git+${url}.git#tag=${pkgver}")
+md5sums=('SKIP') #autofill using updpkgsums
+
+build() {
+ arch-meson $pkgname build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ DESTDIR="${pkgdir}" meson install -C build
+} \ No newline at end of file