summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 51defa0d6e13..4401c39be71e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
-# Maintainer: Jake Leahy <jake@lowerCaseLastName.dev
+# Maintainer: Jake Leahy <jake@lowerCaseLastName.dev>
pkgname=typst-lsp-bin
pkgver=0.3.2
-pkgrel=3
-pkgdesc="A brand-new language server for Typst,"
+pkgrel=4
+pkgdesc="A brand-new language server for Typst"
arch=("x86_64" "armv7h" "aarch64")
url="https://github.com/nvarner/typst-lsp"
license=("MIT")
-source_x86_64=("typst-lsp_x86_64-$pkgver::https://github.com/nvarner/typst-lsp/releases/download/v$pkgver/typst-lsp-linux-x64")
-source_armv7h=("typst-lsp_armv7-$pkgver::https://github.com/nvarner/typst-lsp/releases/download/v$pkgver/typst-lsp-linux-armhf")
-source_aarch64=("typst-lsp_aarch64-$pkgver::https://github.com/nvarner/typst-lsp/releases/download/v$pkgver/typst-lsp-linux-arm64")
+source_x86_64=("typst-lsp-x86_64-$pkgver::https://github.com/nvarner/typst-lsp/releases/download/v$pkgver/typst-lsp-linux-x64")
+source_armv7h=("typst-lsp-armv7h-$pkgver::https://github.com/nvarner/typst-lsp/releases/download/v$pkgver/typst-lsp-linux-armhf")
+source_aarch64=("typst-lsp-aarch64-$pkgver::https://github.com/nvarner/typst-lsp/releases/download/v$pkgver/typst-lsp-linux-arm64")
sha256sums_x86_64=('0b3f629ea1350fb03c864661949d338b5d720b5aefbc72f0241fa3c60b020dad')
sha256sums_armv7h=('c72ec0e4298ccb0109f26f48af810996d069a5dedfdab56591c38821b8beded8')
@@ -21,5 +21,5 @@ depends=("glibc" "gcc-libs")
package() {
cd "$srcdir/"
- install -Dm 755 typst-lsp-$pkgver "${pkgdir}/usr/bin/typst-lsp"
+ install -Dm 755 typst-lsp-$CARCH-$pkgver "${pkgdir}/usr/bin/typst-lsp"
}