summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 12 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9762fa7128b0..d0837924ab3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Theodore Huang <teddyhuangnan@gmail.com>
pkgname=typstfmt-bin
-pkgver=0.2.7
-pkgrel=2
+pkgver=0.2.10
+pkgrel=1
pkgdesc="Basic formatter for the Typst language with a future!"
arch=("x86_64" "aarch64" "armv7h")
url="https://github.com/astrale-sharp/typstfmt"
@@ -10,24 +10,24 @@ provides=("typstfmt")
conflicts=("typstfmt-git")
changelog=$pkgname.changelog
source=(
- LICENSE-APACHE::https://raw.githubusercontent.com/astrale-sharp/typstfmt/main/LICENSE-APACHE
- LICENSE-MIT::https://raw.githubusercontent.com/astrale-sharp/typstfmt/main/LICENSE-MIT
- )
+ LICENSE-APACHE::https://raw.githubusercontent.com/astrale-sharp/typstfmt/main/LICENSE-APACHE
+ LICENSE-MIT::https://raw.githubusercontent.com/astrale-sharp/typstfmt/main/LICENSE-MIT
+)
source_x86_64=(
- $pkgname-x86_64-$pkgver.tar.xz::https://github.com/astrale-sharp/typstfmt/releases/download/$pkgver/typstfmt-x86_64-unknown-linux-musl.tar.xz
+ $pkgname-x86_64-$pkgver.tar.xz::https://github.com/astrale-sharp/typstfmt/releases/download/$pkgver/typstfmt-x86_64-unknown-linux-musl.tar.xz
)
source_aarch64=(
- $pkgname-aarch64-$pkgver.tar.xz::https://github.com/astrale-sharp/typstfmt/releases/download/$pkgver/typstfmt-aarch64-unknown-linux-musl.tar.xz
+ $pkgname-aarch64-$pkgver.tar.xz::https://github.com/astrale-sharp/typstfmt/releases/download/$pkgver/typstfmt-aarch64-unknown-linux-musl.tar.xz
)
source_armv7h=(
- $pkgname-armv7h-$pkgver.tar.xz::https://github.com/astrale-sharp/typstfmt/releases/download/$pkgver/typstfmt-armv7-unknown-linux-musleabi.tar.xz
+ $pkgname-armv7h-$pkgver.tar.xz::https://github.com/astrale-sharp/typstfmt/releases/download/$pkgver/typstfmt-armv7-unknown-linux-musleabi.tar.xz
)
# checksum generate with 'makepkg -g'
sha256sums=('3905892d35c90001cd11101d367d4073b773f30fa7ce868748969f4cc1fb24c2'
'7e302d0694378f3f9584985cf56db84d89b0bcb9f78d04381397349ff50162af')
-sha256sums_x86_64=('ac0ec3a4a9099b9737d2a79b02173c4444835e4bc873eb7ed446fe5f5b87d2f4')
-sha256sums_aarch64=('80e990e47c5291c166cb1d5c6f22d17f7779b2644abf2543cef834c8dc3dfc10')
-sha256sums_armv7h=('3125f28e14d090f64d0b649060863c34b517ea9b1cc4e3da0e122797d3fe9a0c')
+sha256sums_x86_64=('15211663a65a5cff67390480d21618e11aed54defaa00cde2fde3a3ecf812239')
+sha256sums_aarch64=('775ebd2a5905b7b50b8b08c025bbf0ca7d272ee2b7a2b600d2ce2b0ea14baa39')
+sha256sums_armv7h=('274cb1dbb18c72a84eed47301279b0a39cfe9b44330633ad56d952e5a0336b03')
build() {
if [ $CARCH == "x86_64" ]; then
@@ -48,4 +48,4 @@ package() {
cd "$srcdir/"
install -Dm644 LICENSE-APACHE "$pkgdir/usr/share/licenses/$pkgname/LICENSE-APACHE"
install -Dm644 LICENSE-MIT "$pkgdir/usr/share/licenses/$pkgname/LICENSE-MIT"
-}
+} \ No newline at end of file