summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 14 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 82e30a618647..377d4b0ecb78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,22 @@
# Maintainer: Chris Down <chris@chrisdown.name>
pkgname=tzupdate
-pkgver=2.1.0
+pkgver=3.1.0
pkgrel=1
pkgdesc='Set the system timezone based on IP geolocation'
-url=http://github.com/cdown/tzupdate
-arch=(any)
-license=('Public Domain')
-depends=(python python-setuptools)
-source=("https://github.com/cdown/tzupdate/archive/${pkgver}.zip")
-md5sums=('d1bfe48af64922eca1553d4f553d74cc')
+url=https://github.com/cdown/tzupdate
+arch=('x86_64')
+license=('MIT')
+makedepends=('cargo')
+source=("$url/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('aebf678afd261852bd3ebf4689a9a7382c3e4e43a92864b77cbee2d26ec62e22')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ cargo build --release --locked
+}
package() {
- cd "${srcdir?}/$pkgname-$pkgver" || return 1
- python setup.py install --root="${pkgdir?}"
+ cd "$srcdir/$pkgname-$pkgver"
+ cargo install --no-track --locked --root "$pkgdir/usr" --path .
}