summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 14 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 150eaa081322..5702a1cd1ac8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,28 @@
# Maintainer: Caleb Maclennan <caleb@alerque.com>
pkgname=u2o-git
-pkgver=0.6_2_gc84f35f
+pkgver=0.7_0_gb8194e0
pkgrel=1
_branch=master
-pkgdesc="USFM to OSIS bible format converter"
-arch=('any')
-url="https://github.com/adyeths/u2o"
-license=('unlicense')
-depends=('python')
-options=(!emptydirs)
+pkgdesc='USFM to OSIS bible format converter'
+arch=(any)
+url=https://github.com/adyeths/u2o
+license=(Unlicense)
+depends=(python)
+makedepends=(git)
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=("git://github.com/adyeths/${pkgname%-git}.git#branch=$_branch")
+source=("git+$url.git#branch=$_branch")
sha256sums=('SKIP')
pkgver() {
- cd "${pkgname%-git}"
- git describe --long --tags | sed 's/^v//;s/-/_/g'
+ cd "${pkgname%-git}"
+ git describe --always --long --tags --abbrev=7 HEAD |
+ sed 's/^v//;s/-/_/g'
}
package() {
- cd "${pkgname%-git}"
- mkdir -p "$pkgdir"/usr/bin
- install -m0755 u2o.py "$pkgdir"/usr/bin/u2o
- install -m0755 utaglist.py "$pkgdir"/usr/bin/utaglist
+ cd "${pkgname%-git}"
+ install -Dm0755 u2o.py "$pkgdir/usr/bin/u2o"
+ install -Dm0755 utaglist.py "$pkgdir/usr/bin/utaglist"
}