summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 16 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 554f6a73da70..b5cbe04a6eb3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,30 @@
-# Maintainer: Sam Stuewe <halosghost at archlinux dot info>
+# Maintainer: Alexander Shpilkin <ashpilkin at gmail dot com>
+# Contributor: Sam Stuewe <halosghost at archlinux dot info>
pkgname=uacme
-pkgver=v1.0.17
-pkgrel=2
-pkgdesc='An ACMEv2 client written in plain C code with minimal dependencies'
+pkgver=1.7.5
+_pkgsha=fa5e576623ea8f68249e35cdea10c900ba34d8b3 # git show-ref upstream/$pkgver
+pkgrel=1
+pkgdesc='An ACMEv2 client written in plain C with minimal dependencies'
arch=('i686' 'x86_64')
url='https://github.com/ndilieto/uacme/'
-makedepends=('asciidoc')
+makedepends=('asciidoc' 'git' 'libev')
depends=('curl' 'gnutls')
-license=('GPL')
-source=("https://github.com/ndilieto/$pkgname/archive/$pkgver.tar.gz")
-md5sums=('41bbf128aff602a0b59d67c1e405eece') # not upstream
+optdepends=('libev: for ualpn')
+license=('GPL3')
+source=("$pkgname-$pkgver::git+https://github.com/ndilieto/$pkgname.git#tag=$_pkgsha?signed")
+sha256sums=('SKIP')
+validpgpkeys=('243828049BB5F549446516E24142E3D6318A7874') # gpg --fetch-keys https://github.com/ndilieto.gpg
build() {
- cd "$pkgname-${pkgver//v/}"
-
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
make
}
-prepare() {
- cd "$pkgname-${pkgver//v/}"
-
- ./configure --prefix='/usr'
-}
-
package() {
- cd "$pkgname-${pkgver//v/}"
-
- make DESTDIR="$pkgdir" PREFIX='/usr' install
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
}
# vim:set ts=2 sw=2 et: