summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 11 insertions, 30 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9d45cba019fd..8a6c2110d504 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# Maintainer: Darren Wu <$(base64 --decode <<<'ZGFycmVuMTk5NzA4MTBAZ21haWwuY29tCg==')>
+# Maintainer: Darren Ng <$(base64 --decode <<<'ZGFycmVuMTk5NzA4MTBAZ21haWwuY29tCg==')>
pkgname="uasm"
-pkgver=2.47.1
+pkgver=2.50
pkgrel=1
-pkgdesc="free MASM-compatible assembler based on JWasm"
+pkgdesc="Continued evolution of JWasm" # http://www.terraspace.co.uk/uasm.html#p1
arch=('x86_64')
url="http://www.terraspace.co.uk/uasm.html"
license=(
@@ -11,48 +11,29 @@ license=(
'custom:Sybase Open Watcom Public License'
)
# options=(!strip debug)
-# options=(!strip)
-# PKGEXT=.pkg.tar
-# source=('uasm::git+https://github.com/Terraspace/UASM.git#branch=v2.47.1')
source=(
- # https://travis-ci.org/Terraspace/UASM/branches
- 'uasm::git+https://github.com/Terraspace/UASM.git#commit=f36556139c658bb8f970579d6d84497210d10958'
- 'suppress_color_from_help.patch'
+ # 'uasm::git+https://github.com/Terraspace/UASM.git#branch=v5.0'
+ 'uasm::git+https://github.com/Terraspace/UASM.git#commit=41002d262d3a9d6ca737d72e86f6f1328d42478d'
+ 'uasm-default-nocolor.sh'
)
md5sums=(
'SKIP'
- '7a0e3562bfd82b3b9470bc67aaad2b03'
+ '16ee809dee22b3f4aa39536330b5c117'
)
-
-prepare() {
-
- # if [ "$(git rev-parse HEAD)"!="f36556139c658bb8f970579d6d84497210d10958" ];then
- # echo "Error."
- # echo "Branch v2.47.1 should be at f36556139c658bb8f970579d6d84497210d10958."
- # exit 1
- # fi
-
- patch --verbose "$srcdir/$pkgname/errmsg.c" "$srcdir/suppress_color_from_help.patch"
- # patch -p1 -i "$srcdir/$pkgname-$pkgver.patch"
-
-}
-
build() {
cd "$srcdir/$pkgname"
- # CFLAGS="-g" CXXFLAGS="-g" DEBUG=1 make -f GccUnix.mak
- make -f GccUnix.mak
+ make -f gccLinux64.mak
}
-
package() {
cd "$srcdir/$pkgname"
- install -v -Dm755 GccUnixR/uasm "$pkgdir/usr/bin/uasm"
+ install -v -Dm755 GccUnixR/uasm "$pkgdir/usr/bin/uasm-color"
+ install -v -Dm755 "$srcdir/uasm-default-nocolor.sh" "$pkgdir/usr/bin/uasm"
install -v -dDm755 "$pkgdir/usr/share/doc/uasm"
-
- install -v -m644 Readme.txt History.txt Doc/* "$pkgdir/usr/share/doc/uasm/" # 7 txts
+ install -v -m644 Readme.txt History.txt Doc/* "$pkgdir/usr/share/doc/uasm/"
install -v -Dm644 License.txt "$pkgdir/usr/share/licenses/$pkgname/License.txt"
}