summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d07f694b7af4..ae415ff373aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,16 @@
+# Maintainer: Rhys Perry <rhysperry111 AT gmail.com>
# Contributor: Lex Black <autumn-wind@web.de>
_gitname=ubertooth
pkgname=ubertooth-git
pkgver=2020.12.R1.r33.ge0fd34d
-pkgrel=1
+pkgrel=2
pkgdesc="open source wireless development platform suitable for Bluetooth experimentation"
url="https://github.com/greatscottgadgets/ubertooth"
arch=('x86_64' 'i686')
license=('GPL2')
-depends=('libbtbb-git' 'libusb' 'libpcap' 'python')
-makedepends=('git' 'cmake')
+depends=('libbtbb-git' 'libusb' 'libpcap' 'python' 'python-libusb1')
+makedepends=('git' 'cmake' 'python-setuptools')
source=(git+https://github.com/greatscottgadgets/ubertooth/)
md5sums=('SKIP')
@@ -25,9 +26,15 @@ build() {
cd build
cmake -DCMAKE_INSTALL_PREFIX=${pkgdir}/usr ..
make
+
+ cd ../python/ubtbr/
+ python setup.py build
}
package() {
cd "$_gitname/host/build/"
make install
+
+ cd ../python/ubtbr/
+ python setup.py install --root="$pkgdir"
}