summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 15 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8cecfb6ee519..d07f694b7af4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,26 @@
+# Contributor: Lex Black <autumn-wind@web.de>
+
_gitname=ubertooth
pkgname=ubertooth-git
-pkgver=2017.03.R2
-epoch=2
+pkgver=2020.12.R1.r33.ge0fd34d
pkgrel=1
-pkgdesc="an open source wireless development platform suitable for Bluetooth experimentation"
+pkgdesc="open source wireless development platform suitable for Bluetooth experimentation"
url="https://github.com/greatscottgadgets/ubertooth"
arch=('x86_64' 'i686')
license=('GPL2')
-depends=('libbtbb-git' 'libusbx' 'libpcap' 'python')
-source=("https://github.com/greatscottgadgets/ubertooth/archive/master.zip")
+depends=('libbtbb-git' 'libusb' 'libpcap' 'python')
+makedepends=('git' 'cmake')
+source=(git+https://github.com/greatscottgadgets/ubertooth/)
md5sums=('SKIP')
+
+pkgver() {
+ cd "$_gitname"
+ git describe --tags --long --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
build() {
- cd "${srcdir}/${_gitname}-master/host/"
+ cd "$_gitname/host/"
mkdir -p build
cd build
cmake -DCMAKE_INSTALL_PREFIX=${pkgdir}/usr ..
@@ -20,6 +28,6 @@ build() {
}
package() {
- cd "${srcdir}/${_gitname}-master/host/build/"
+ cd "$_gitname/host/build/"
make install
}