summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 4 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b0d238a541d3..e6e77fdf37e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
# Contributor: Ewout van Mansom <ewout@vanmansom.name>
pkgname='ubuntu-wallpapers'
-pkgver=22.12.1
+pkgver=23.04.1
pkgrel=1
pkgdesc='The default Wallpapers for Ubuntu'
arch=('any')
@@ -20,21 +20,15 @@ makedepends=('python-distutils-extra' 'python-setuptools')
# http://archive.ubuntu.com/ubuntu/pool/main/u/ubuntu-wallpapers/
source=(
"${_pool_url}/${pkgname::1}/${pkgname}/${pkgname}_${pkgver}.orig.tar.gz"
- "${_pool_url}/${pkgname::1}/${pkgname}/${pkgname}_${pkgver}-0ubuntu1.debian.tar.xz"
- 'setuptools-bugfix.patch'
+ "${_pool_url}/${pkgname::1}/${pkgname}/${pkgname}_${pkgver}.debian.tar.xz"
)
-sha512sums=('cc2b1d2db963c2657d863c95eaa49afb92a1dd38da59ac8b1dba931af7ca1f8b1402db1bf8ad7034749846283ff94129012e57f15f457a0afb8d4ef95ce2aaed'
- '3d38de8183838c405ff222361c48ce698581ab3852fc3816b2c972b24420dc1f744b0b2617ae728cc59534eba4729a40b0a7b8c4611fc125fbd69faf95a927fc'
- '4d562ef7ccc6add6d966c111ed8f93b5c020a2be57bc468b427768521e64533536fb8b968a5430979f5d36f2de34bc82fb9ee3adca42f0194bb0d95c757cfe70')
+sha512sums=('d611d822f81fb1d8c17bf23881b09d5c4a385ea611b9cd74280fb741845cba0feecb6bc093b24d399b38e541650ecb24dcc5336894a0bb1b570cfac091107716'
+ 'd22b84fe966b0393e4ba331e5e3b2726811c63e06072bd3e148e90c92ee9877cf1ead7c63a6bdad97b71e5e0dffd7f9eb08b007266685b2b0c81126cec3dfe09')
prepare() {
cd "${pkgname}-${pkgver}"
# The setup.py script reads the package version from debian/*
ln -sfv ../debian .
- # Patch setuptools to work around new behavior in setuptools
- # Eventually this can be removed, whenever Ubuntu/Debian package maintainers
- # Stumble on this and fix it upstream.
- patch --forward --strip=1 --input="${srcdir}/setuptools-bugfix.patch"
}
package() {