summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 4 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c86064feeee0..eb350591aa1c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Contributor: robb_force <robb_force@holybuffalo.net>
pkgname=ucon64
-pkgver=2.2.1
-pkgrel=2
+pkgver=2.2.2
+pkgrel=1
pkgdesc="A ROM backup tool and emulator's Swiss Army knife program."
arch=('i686' 'x86_64')
url="https://ucon64.sourceforge.io/index.php"
@@ -13,22 +13,13 @@ license=('GPL')
depends=('zlib' 'libusb-compat')
optdepends=('libieee1284: libcd64 enhancements')
source=(https://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}-src.tar.gz)
-sha256sums=('e814f427a59866e16fe757bf4af51004ac68be29cabd78944590878f1df73f79')
-
-# Apply a minor patch affecting 64-bit systems, the bug of which was found
-# just a few days after the release of 2.2.1. It won't be needed in the next
-# release.
-source+=(https://sourceforge.net/projects/${pkgname}/files/${pkgname}/${pkgname}-${pkgver}/patches/change_mem2.patch)
-sha256sums+=('65ff85255878e077c2e5fc57565cf0b93833ce8ac03bf81d46ba91ec837accf7')
+sha256sums=('e100ad4a30f6c19abde98e361c6a0ecac4e40477f54cfb75498c5ccd21fb3a18')
srcroot="${pkgname}-${pkgver}-src/src"
prepare()
{
- patch -d "${srcdir}" -p2 < ../aur_discmage_path.patch
-
- # XXX Remember to remove this patch on the next release (>2.2.1)
- patch -d "${srcdir}" -p0 < change_mem2.patch
+ patch -d "${srcroot}" -p2 < ../aur_discmage_path.patch
}
build()