summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d6e8997fe74a..b01c22a3e7b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,22 @@
# Maintainer: Maarten van Gompel <proycon at anaproy dot nl>
pkgname=ucto
-pkgver=0.8.0
+pkgver=0.8.2
pkgrel=1
pkgdesc="An advanced rule-based (regular-expression) and unicode-aware tokenizer for various languages. Tokenization is an essential first step in any NLP pipeline."
arch=('i686' 'x86_64')
license=('GPL3')
-depends=('ticcutils>=0.7' 'icu' 'libxml2' 'libfolia>=0.13')
-makedepends=('libtool' 'autoconf')
+depends=('ticcutils>=0.11' 'icu' 'libxml2' 'libfolia>=0.13')
+makedepends=('libtool' 'autoconf' 'autoconf-archive')
options=(!libtool)
-url="http://ilk.uvt.nl/ucto"
-source=("http://software.ticc.uvt.nl/$pkgname-$pkgver.tar.gz")
-md5sums=('67750bc54be80bdc9bb47acf8e5aa616')
+_gituser="LanguageMachines"
+_gitname="ucto"
+url="https://languagemachines.github.io/ucto"
+source=(https://github.com/LanguageMachines/ucto/archive/v0.8.2.tar.gz)
+md5sums=(7d2443b5e88b8312c0a48e5e169c7d8a)
build() {
cd $srcdir/$pkgname-$pkgver
+ bash bootstrap.sh
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
make
}