summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..37cbb9e4618d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Devin J. Pohly <djpohly+arch@gmail.com>
+pkgname=udf-infusion-git
+_pkgname=${pkgname%-git}
+_reponame=udf_infusion
+pkgver=r104.25c3613
+pkgrel=1
+pkgdesc="MySQL functionality enhancement UDF"
+arch=('i686' 'x86_64')
+url="https://github.com/infusion/udf_infusion"
+license=('GPL2')
+depends=('gcc-libs')
+makedepends=('mysql')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+https://github.com/infusion/udf_infusion")
+sha256sums=(SKIP)
+
+pkgver() {
+ cd "$_reponame"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_reponame"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$_reponame"
+ make DESTDIR="$pkgdir/" install
+}