summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0a17e438f131..45a77a5f65b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: JustKidding <jk@vin.ovh>
pkgname=ueberzugpp
-pkgver=2.8.9
-pkgrel=2
+pkgver=2.9.0
+pkgrel=1
pkgdesc="Command line util which allows to display images in combination with X11 written in C++"
arch=(any)
url="https://github.com/jstkdng/ueberzugpp"
license=("GPL3")
makedepends=("cmake" "cli11" "nlohmann-json" "microsoft-gsl" "wayland-protocols" "extra-cmake-modules")
-depends=("opencv" "libvips" "glib2" "libxcb" "xcb-util-image" "libsixel" "openssl" "spdlog"
+depends=("opencv" "libvips" "glib2" "libxcb" "xcb-util-image" "libsixel" "openssl" "spdlog" "libglvnd"
"fmt" "turbo-base64" "chafa" "wayland" "onetbb" "glibc" "gcc-libs" "xcb-util-errors")
source=("https://github.com/jstkdng/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('eeff6a6583b84620b7893e44b386fbcb828c1987ec193ac486c391f316d091c8')
+sha256sums=('c982b7648113fb65fe2f993e80b34f5854f7f532de873d71efdeabe1ca03e9da')
provides=("ueberzug")
conflicts=("ueberzug")
options=("debug")
@@ -23,6 +23,7 @@ build() {
-DENABLE_TURBOBASE64=ON \
-DENABLE_WAYLAND=ON \
-DENABLE_XCB_ERRORS=ON \
+ -DENABLE_OPENGL=ON \
-Wno-dev
cmake --build build -j $(nproc)
}