summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 760e02bae062..b7530d2218c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=ufodiff
pkgver=1.0.3
-pkgrel=2
+pkgrel=3
pkgdesc='UFO source file diff application'
arch=(any)
url="https://github.com/source-foundry/$pkgname"
@@ -13,17 +13,18 @@ depends=(python
python-gitpython
python-smmap
python-standardstreams)
-makedepends=(python-setuptools)
+makedepends=(python-{build,installer,wheel}
+ python-setuptools)
_archive="$pkgname-$pkgver"
source=("$_archive.tar.gz::$url/archive/v$pkgver.tar.gz")
sha256sums=('e549e7f3598c0cf0a6be207944fb632db0d834addb4cf202ee00967ceebd58dd')
build() {
cd "$_archive"
- python setup.py build
+ python -m build -wn
}
package() {
cd "$_archive"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer -d "$pkgdir" dist/*.whl
}