summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b3fed0be3184..e46650d47119 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,22 @@
_usdx_package=WorldParty
_pkgname=ultrastardxwp
+_ffmpeg="ffmpeg"
pkgname=${_pkgname}-git
-pkgver=r25.9f5f917
+pkgver=r367.532b1ca
pkgrel=1
pkgdesc="UltraStar Deluxe WorldParty is a free and open source karaoke game. It allows up to six players to sing along with music using microphones in order to score points, depending on the pitch of the voice and the rhythm of singing."
arch=("i686" "x86_64")
url="http://ultrastar-es.org"
license=("GPL")
-depends=("ffmpeg2.8" "lua" "pcre" "portaudio" "sdl2" "sdl2_gfx" "sdl2_mixer" "sdl2_ttf" "sdl2_image" "sdl2_net" "sqlite" "ttf-dejavu" "ttf-freefont")
+depends=(${_ffmpeg} "lua" "pcre" "portaudio" "sdl2" "sdl2_gfx" "sdl2_mixer" "sdl2_ttf" "sdl2_image" "sdl2_net" "sqlite" "ttf-dejavu" "gnu-free-fonts")
makedepends=("git" "fpc")
optdepends=()
conflicts=("${pkgname}")
options=("!buildflags")
install=${pkgname}.install
source=("${_pkgname}.desktop"
- "${_pkgname}::git+https://github.com/ultrastares/usdxworldparty/")
+ "${_pkgname}::git+https://github.com/ultrastares/usdxworldparty")
md5sums=('45e724d9c3ab756ed908774daedfac24'
'SKIP')
@@ -35,13 +36,13 @@ prepare() {
build() {
cd "${srcdir}/${_pkgname}"
chmod +x configure
- PKG_CONFIG_PATH="/usr/lib/ffmpeg2.8/pkgconfig" ./configure --prefix=/usr
+ PKG_CONFIG_PATH="/usr/lib/${_ffmpeg}/pkgconfig" ./configure --prefix=/usr
make
}
package() {
cd "${srcdir}/${_pkgname}"
- make install DESTDIR="$pkgdir"
+ make install DESTDIR="${pkgdir}"
install -Dm644 "${srcdir}/${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
install -Dm644 "${pkgdir}/usr/share/${_usdx_package}/resources/icons/${_usdx_package}.png" "${pkgdir}/usr/share/icons/${_usdx_package}.png"
}