summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8dd41fd76006..0c0b4088838e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,24 @@
-# Maintainer: Andreas Wagner <AndreasBWagner@pointfree.net>
+# Maintainer: Alwyn Kik <alwyn@proteon.com>
+# Contributor: Andreas Wagner <AndreasBWagner@pointfree.net>
# Contributor: Gerardo Exequiel Pozzi <vmlinuz386@yahoo.com.ar>
-pkgname=unbuffered
-pkgver=0.5.2
+pkgname=unbuffered-git
+pkgver=r1.f73865a
pkgrel=1
-pkgdesc="Copy stdin to stdout and stderr, unbuffered"
+pkgdesc="Copy stdin to stdout and stderr, unbuffered, development version"
arch=('i686' 'x86_64')
url="http://www.scylla-charybdis.com/tool.php/${pkgname}"
-license=('GPL2+')
+license=('GPL2')
depends=('glibc')
-changelog='ChangeLog'
-source=(${pkgname}-${pkgver}::'git+https://github.com/hilbix/unbuffered.git#commit=f3004614e5da8bcdec2007c0eb98a61c5101ea20')
+makedepends=('git')
+changelog=ChangeLog
+source=(${pkgname}-${pkgver}::'git+https://github.com/hilbix/unbuffered.git#commit=f73865a6cd253052312b154ca4c2e9e1e2f5ce47')
sha512sums=('SKIP')
build() {
cd "$srcdir/${pkgname}-${pkgver}"
git submodule update --init
- make ${pkgname}_version.h
+ make unbuffered_version.h
sed -i 's/\r//' $srcdir/${pkgname}-${pkgver}/unbuffered_version.h
make
}