summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b70c8f67e8c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+pkgdesc="XDG sound theme for the unexicon distribution"
+pkgname=unexicon-sound-theme-git
+_pkgname=unexicon-sound-theme
+pkgver=1.0.r1.g38e8a0d
+pkgrel=1
+arch=('any')
+license=('GPL')
+url="https://github.com/bbidulock/${_pkgname}"
+groups=('unexicon')
+provides=("${_pkgname}=${pkgver%%.r*}-${pkgrel}")
+conflicts=("${_pkgname}")
+depends=('sound-theme-freedesktop' 'sound-theme-smooth' 'linux-a11y-sound-theme')
+makedepends=('git' 'pkgconfig' 'flite' 'flite-voices' 'sox')
+source=("$pkgname::git://github.com/bbidulock/$_pkgname.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --long --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd $pkgname
+ ./autogen.sh
+}
+
+build() {
+ cd $pkgname
+ ./configure
+ make
+}
+
+package() {
+ make -C ${pkgname} DESTDIR="${pkgdir}" install
+}
+