summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 08bbaf5cec3c..232abcc7c2ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,8 +9,8 @@
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=ungoogled-chromium
-pkgver=108.0.5359.98
-pkgrel=2
+pkgver=108.0.5359.124
+pkgrel=1
_launcher_ver=8
_gcc_patchset=2
pkgdesc="A lightweight approach to removing Google web service dependency"
@@ -21,9 +21,10 @@ depends=('gtk3' 'nss' 'alsa-lib' 'xdg-utils' 'libxss' 'libcups' 'libgcrypt'
'ttf-liberation' 'systemd' 'dbus' 'libpulse' 'pciutils' 'libva'
'wayland' 'desktop-file-utils' 'hicolor-icon-theme')
makedepends=('python' 'gn' 'ninja' 'clang' 'lld' 'gperf' 'nodejs' 'pipewire'
- 'java-runtime-headless' 'git')
+ 'qt5-base' 'java-runtime-headless' 'git')
optdepends=('pipewire: WebRTC desktop sharing under Wayland'
'kdialog: support for native dialogs in Plasma'
+ 'qt5-base: enable Qt5 with --enable-features=AllowQt'
'org.freedesktop.secrets: password storage backend on GNOME / Xfce'
'kwallet: support for storing passwords in KWallet on Plasma')
options=('debug' '!lto') # Chromium adds its own flags for ThinLTO
@@ -38,7 +39,7 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/chrom
disable-GlobalMediaControlsCastStartStop.patch
angle-wayland-include-protocol.patch
use-oauth2-client-switches-as-default.patch)
-sha256sums=('60b6137971e3cb2947477f654491ed4f517ab88ea2807fa3b89fcce34b83561e'
+sha256sums=('d48dfac2a61b14a5d7d2f460b09b70ef3ab88e27b82e3173938cb54eaa612a75'
'213e50f48b67feb4441078d50b0fd431df34323be15be97c55302d3fdac4483a'
'40ef8af65e78901bb8554eddbbb5ebc55c0b8e7927f6ca51b2a353d1c7c50652'
'9015b9d6d5b4c1e7248d6477a4b4b6bd6a3ebdc57225d2d8efcd79fc61790716'
@@ -59,7 +60,7 @@ source=(${source[@]}
ozone-add-va-api-support-to-wayland.patch
remove-main-main10-profile-limit.patch)
sha256sums=(${sha256sums[@]}
- '91afcb2ab483b226979b4114ba5ce2aa462658688c10cafd29f78c4be607357e'
+ 'ac71aa130e70bcb5b30fc5f899239851b4bff05938cf4fe6d3f8c2da04e85f70'
'e9e8d3a82da818f0a67d4a09be4ecff5680b0534d7f0198befb3654e9fab5b69'
'fc810e3c495c77ac60b383a27e48cf6a38b4a95b65dd2984baa297c5df83133c')
@@ -209,7 +210,6 @@ build() {
'link_pulseaudio=true'
'use_custom_libcxx=false'
'use_gnome_keyring=false'
- 'use_qt=false' # look into enabling this
'use_sysroot=false'
'use_system_libwayland=true'
'use_system_wayland_scanner=true'
@@ -300,6 +300,7 @@ package() {
chrome_100_percent.pak
chrome_200_percent.pak
chrome_crashpad_handler
+ libqt5_shim.so
resources.pak
v8_context_snapshot.bin