summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD85
1 files changed, 31 insertions, 54 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 786748231fce..621e0cbedb43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,15 +8,17 @@
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=ungoogled-chromium-ozone
-pkgver=84.0.4147.135
+pkgver=85.0.4183.102
pkgrel=1
-_pkgname=ungoogled-chromium
-_pkgver=$pkgver
-_ungoogled_ver=$pkgver-1
-_uc_url="$_pkgname-$_ungoogled_ver.tar.gz::https://github.com/Eloston/ungoogled-chromium/archive/$_ungoogled_ver.tar.gz"
-_uc_sum="69195a85612076ceea22b787b2d49b9f22aebd815b5ea2e0dd88f071c89d949b"
_launcher_ver=6
-_gcc_patchset=3
+_gcc_patchset=2
+_pkgname=$(echo $pkgname | cut -d\- -f1-2)
+_pkgver=$(echo $pkgver | cut -d\. -f1-4)
+# ungoogled chromium variables
+_uc_ver=$pkgver-1
+_uc_usr=Eloston
+_uc_sum='c5f157a1cad84699ea420caf318ab84ae56f11972b67cfb7b95cf9eb072cc12f'
+_uc_url="$_pkgname-$_uc_ver.tar.gz::https://github.com/$_uc_usr/ungoogled-chromium/archive/$_uc_ver.tar.gz"
pkgdesc="A lightweight approach to removing Google web service dependency with patches for wayland support via Ozone"
arch=('x86_64')
url="https://github.com/Eloston/ungoogled-chromium"
@@ -41,31 +43,23 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/chrom
chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
chromium-drirc-disable-10bpc-color-configs.conf
https://github.com/stha09/chromium-patches/releases/download/chromium-${pkgver%%.*}-patchset-$_gcc_patchset/chromium-${pkgver%%.*}-patchset-$_gcc_patchset.tar.xz
- remove-NotifyError-calls-and-just-send-a-normal-message.patch
- avoid-calling-DeleteForCurrentDocument-from-destructor.patch
- force-mp3-files-to-have-a-start-time-of-zero.patch
- chromium-ffmpeg-4.3.patch
+ media-Set-allocation-limit-compatible-with-FFmpeg-4.3.patch
intel-vp9-quirk.patch
wayland-egl.patch
nvidia-vdpau.patch
chromium-skia-harmony.patch)
-sha256sums=('dd41001596d0e17051ddcece3db6c0cdbe92fe23375d56fbcfba624a5f4996d8'
+sha256sums=('8a68d474724a7a8acfc7742405942836f08e30e713f12f8c3ada46ee6a805e0c'
$_uc_sum
'04917e3cd4307d8e31bfb0027a5dce6d086edb10ff8a716024fbb8bb0c7dccf1'
'babda4f5c1179825797496898d77334ac067149cac03d797ab27ac69671a7feb'
- 'f77088dd59b170b767ba91c6b410abb778ff2e68553433b24124d398fa4d3ce7'
- '3b10917f646f88ae988ca18be9cbef82025abb6a6e5cb00b77a11077192ce32c'
- '4e41cb637e96bcef98c119ed052ba1aeab45fca5b89d65955583dab002de783e'
- 'abc3fad113408332c3b187b083bf33eba59eb5c87fa3ce859023984b5804623c'
- '5390304b5f544868985ce00a3ec082d4ece2dacb1c73cdb35dd4facfea12449a'
+ '2194fe22b9e5ccdc4a86da4e3572214f670c561486671f57c90636fd3cbfa43e'
+ '0f041d655335cd2a4773ae7ca5e301a0ff12c6c53f57b7cf6651c268e0420a1c'
'a25fc6fccb84fd0a58a799661cd9c4ffeb2731fa49268f43aa7108f1542c5af6'
'34d08ea93cb4762cb33c7cffe931358008af32265fc720f2762f0179c3973574'
'8095bf73afbca7c2b07306c5b4dd8f79b66e1053fa4e58b07f71ef938be603f1'
'771292942c0901092a402cc60ee883877a99fb804cb54d568c8c6c94565a48e1')
-source+=(fix-vaapi-ozone-build.patch
- iwyu-evdev-include-cstring-for-memset-and-memcpy-calls.patch)
-sha256sums+=('4e7f98b093518cc402448bdc2e35deec5cd047c0dad5bcc7b1ff2e5ba7da98aa'
- 'f420fee3fc685209ac9221ddb235e453a471a547dd2149624bf7d1e161186a2c')
+source+=(fix-compilation.patch)
+sha256sums+=('SKIP')
# Possible replacements are listed in build/linux/unbundle/replace_gn_files.py
# Keys are the names in the above script; values are the dependencies in Arch
@@ -79,7 +73,7 @@ declare -gA _system_libs=(
[libdrm]=
[libjpeg]=libjpeg
[libpng]=libpng
- [libvpx]=libvpx
+ #[libvpx]=libvpx
[libwebp]=libwebp
[libxml]=libxml2
[libxslt]=libxslt
@@ -106,26 +100,12 @@ prepare() {
third_party/blink/renderer/core/xml/parser/xml_document_parser.cc \
third_party/libxml/chromium/*.cc
- # https://chromium-review.googlesource.com/c/chromium/src/+/2223010
- patch -Np1 -i ../remove-NotifyError-calls-and-just-send-a-normal-message.patch
-
- # https://chromium-review.googlesource.com/c/chromium/src/+/2224737
- patch -Np1 -i ../avoid-calling-DeleteForCurrentDocument-from-destructor.patch
-
- # https://chromium-review.googlesource.com/c/chromium/src/+/2268221
- patch -Np1 -i ../force-mp3-files-to-have-a-start-time-of-zero.patch
+ # https://crbug.com/1095962
+ patch -Np1 -i ../media-Set-allocation-limit-compatible-with-FFmpeg-4.3.patch
# Fixes for building with libstdc++ instead of libc++
- patch -Np1 -i ../patches/chromium-84-AXObject-stl-iterator.patch
- patch -Np1 -i ../patches/chromium-84-ListContainerHelper-include-cstring.patch
- patch -Np1 -i ../patches/chromium-84-crashpad-include-cstring.patch
- patch -Np1 -i ../patches/chromium-84-gcc-10-include-stddef.patch
- patch -Np1 -i ../patches/chromium-84-gcc-10-webrtc-include-stddef.patch
- patch -Np1 -i ../patches/chromium-84-gcc-DCHECK_EQ-unique_ptr.patch
- patch -Np1 -i ../patches/chromium-84-std-vector-const.patch
-
- # https://crbug.com/1095962
- patch -Np1 -i ../chromium-ffmpeg-4.3.patch
+ patch -Np1 -i ../patches/chromium-85-NearbyShareEncryptedMetadataKey-include.patch
+ patch -Np1 -i ../patches/chromium-85-sim_hash-include.patch
# https://crbug.com/skia/6663#c10
patch -Np0 -i ../chromium-skia-harmony.patch
@@ -139,14 +119,11 @@ prepare() {
# NVIDIA vdpau-wrapper
patch -Np1 -i ../nvidia-vdpau.patch
- # add missing include
- patch -Np1 -i ../iwyu-evdev-include-cstring-for-memset-and-memcpy-calls.patch
-
- # Fix vaapi linkage error
- patch -Np1 -i ../fix-vaapi-ozone-build.patch
+ # Fix compilation
+ patch -Np1 -i ../fix-compilation.patch
# Ungoogled Chromium changes
- _ungoogled_repo="$srcdir/$_pkgname-$_ungoogled_ver"
+ _ungoogled_repo="$srcdir/$_pkgname-$_uc_ver"
_utils="${_ungoogled_repo}/utils"
msg2 'Pruning binaries'
python "$_utils/prune_binaries.py" ./ "$_ungoogled_repo/pruning.list"
@@ -159,9 +136,6 @@ prepare() {
# Force script incompatible with Python 3 to use /usr/bin/python2
sed -i '1s|python$|&2|' third_party/dom_distiller_js/protoc_plugins/*.py
- # Make xcbgen available to ui/gfx/x/gen_xproto.py running under Python 2
- ln -s /usr/lib/python3.*/site-packages/xcbgen "$srcdir/"
-
mkdir -p third_party/node/linux/node-linux-x64/bin
ln -s /usr/bin/node third_party/node/linux/node-linux-x64/bin/
@@ -192,9 +166,6 @@ build() {
export CCACHE_SLOPPINESS=time_macros
fi
- # ui/gfx/x/gen_xproto.py needs xcbgen
- export PYTHONPATH=$srcdir
-
export CC=clang
export CXX=clang++
export AR=ar
@@ -211,8 +182,8 @@ build() {
'use_gnome_keyring=false'
'use_sysroot=false'
'use_custom_libcxx=false'
+ 'enable_widevine=true'
'use_vaapi=true'
- 'enable_swiftshader=false'
)
if [[ -n ${_system_libs[icu]+set} ]]; then
@@ -225,6 +196,7 @@ build() {
# Append ozone flags
local _ozone_flags=(
+ 'use_x11=true'
'use_ozone=true'
'ozone_platform_wayland=true'
'ozone_platform_x11=true'
@@ -237,7 +209,7 @@ build() {
_flags=("${_flags[@]}" "${_ozone_flags[@]}")
# Append ungoogled chromium flags to _flags array
- _ungoogled_repo="$srcdir/$_pkgname-$_ungoogled_ver"
+ _ungoogled_repo="$srcdir/$_pkgname-$_uc_ver"
readarray -t -O ${#_flags[@]} _flags < "${_ungoogled_repo}/flags.gn"
# Facilitate deterministic builds (taken from build/config/compiler/BUILD.gn)
@@ -296,6 +268,10 @@ package() {
resources.pak
v8_context_snapshot.bin
+ # ANGLE
+ libEGL.so
+ libGLESv2.so
+
chromedriver
)
@@ -305,6 +281,7 @@ package() {
cp "${toplevel_files[@]/#/out/Release/}" "$pkgdir/usr/lib/chromium/"
install -Dm644 -t "$pkgdir/usr/lib/chromium/locales" out/Release/locales/*.pak
+ install -Dm755 -t "$pkgdir/usr/lib/chromium/swiftshader" out/Release/swiftshader/*.so
for size in 24 48 64 128 256; do
install -Dm644 "chrome/app/theme/chromium/product_logo_$size.png" \