summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD66
1 files changed, 33 insertions, 33 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7e461c993420..0e9dfe591f2e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,60 +3,59 @@
pkgname=ungoogled-chromium-ozone
_pkgname=ungoogled-chromium
-pkgver=78.0.3904.108
+pkgver=79.0.3945.79
pkgrel=1
_launcher_ver=6
-pkgdesc="A lightweight approach to removing Google web service dependency"
+pkgdesc="A lightweight approach to removing Google web service dependency with patches for wayland support via Ozone"
arch=('x86_64')
url="https://ungoogled-software.github.io/"
license=('BSD')
depends=('gtk3' 'nss' 'alsa-lib' 'xdg-utils' 'libxss' 'libcups' 'libgcrypt'
- 'ttf-font' 'systemd' 'dbus' 'libpulse' 'pciutils' 'json-glib' 'libva'
- 'icu' 'libxml2' 'fontconfig' 'harfbuzz' 'libjpeg' 're2' 'snappy' 'ffmpeg' 'flac' 'libwebp' 'minizip' 'libxslt' 'freetype2' 'opus'
+ 'ttf-font' 'systemd' 'dbus' 'libpulse' 'pciutils' 'json-glib'
'desktop-file-utils' 'hicolor-icon-theme')
makedepends=('python' 'python2' 'gperf' 'yasm' 'mesa' 'ninja' 'nodejs' 'git'
- 'pipewire' 'clang' 'lld' 'gn' 'jre-openjdk-headless' 'jack')
+ 'pipewire' 'clang' 'lld' 'gn' 'java-runtime-headless')
optdepends=('pepper-flash: support for Flash content'
'kdialog: needed for file dialogs in KDE'
- 'gnome-keyring: for storing passwords in GNOME keyring'
- 'kwallet: for storing passwords in KWallet'
- 'libva-intel-driver: for hardware video acceleration with old Intel GPUs'
- 'intel-media-driver: for hardware video acceleration with newer Intel GPUs'
+ 'org.freedesktop.secrets: password storage backend on GNOME / Xfce'
+ 'kwallet: for storing passwords in KWallet on KDE desktops'
+ 'libva-intel-driver: for hardware video acceleration with Intel GPUs'
+ 'intel-media-driver: for hardware video acceleration with newer intel gpus'
'libva-mesa-driver: for hardware video acceleration with AMD/ATI GPUs'
'libva-vdpau-driver: for hardware video acceleration with NVIDIA GPUs')
provides=('chromium')
conflicts=('chromium')
source=(https://commondatastorage.googleapis.com/chromium-browser-official/chromium-${pkgver}.tar.xz
chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
- 'ungoogled-chromium.zip::https://github.com/Eloston/ungoogled-chromium/archive/master.zip'
+ 'ungoogled-chromium::git+https://github.com/Eloston/ungoogled-chromium'
flags.archlinux.gn
chromium-drirc-disable-10bpc-color-configs.conf
vaapi-fix.patch
fix-vaapi-ozone-build.patch
- add-missing-include-for-unique_ptr.patch
- dns_util-make-DohUpgradeEntry-non-const.patch
- fix-shutdown-crash-in-ProfileManager.patch
+ launch_manager.h-uses-std-vector.patch
+ include-algorithm-to-use-std-lower_bound.patch
icu65.patch
chromium-system-icu.patch
chromium-system-zlib.patch
+ chromium-system-hb.patch
fix-spammy-unique-font-matching-log.patch
chromium-widevine.patch
chromium-skia-harmony.patch)
-sha256sums=('f9c53839f306d2973de27723360024f7904101d426b9e7e9cdb56e8bcc775b0e'
+sha256sums=('e1a7362d396b0f72e6ad8c1d53cae67db201e0eeaa2a96dbe9214d080925bcf3'
'04917e3cd4307d8e31bfb0027a5dce6d086edb10ff8a716024fbb8bb0c7dccf1'
'SKIP'
- 'd81d95f719e7b4ed2c15ece56b0272ae969e8df871f1d8d87065db0130134912'
+ '2f77b02f0e5b2396cdbede4360bd44f71d03844c36bd8c4f038f3e238fac8981'
'babda4f5c1179825797496898d77334ac067149cac03d797ab27ac69671a7feb'
- '9256123898cbdd4da4a111e5aa8752d5c6c2c07e59ca8677751791dd3321f6a9'
+ '0ec6ee49113cc8cc5036fa008519b94137df6987bf1f9fbffb2d42d298af868a'
'9aebd800e5fe191cd5f4bd82c33419eefdd80919e6c6f5a3a9346a224625f094'
- '49052e8aa630c4aa57bf46823edc32b7b309493275163c3bb3f9fd390c73356e'
- '69694ab12a5ced389916c0c5e8c7bdc191544f576b134ddfb2fe9d4ed9ec4494'
- '4f81612c28957987f7344d8ce2b95a4a63136a8319c9751819436b11c62df057'
+ 'bd0fae907c451252e91c4cbf1ad301716bc9f8a4644ecc60e9590a64197477d3'
+ '1f906676563e866e2b59719679e76e0b2f7f082f48ef0593e86da0351a586c73'
'1de9bdbfed482295dda45c7d4e323cee55a34e42f66b892da1c1a778682b7a41'
'e73cc2ee8d3ea35aab18c478d76fdfc68ca4463e1e10306fa1e738c03b3f26b5'
'eb67eda4945a89c3b90473fa8dc20637511ca4dcb58879a8ed6bf403700ca9c8'
+ 'c0ad3fa426cb8fc1a237ddc6309a6b2dd4055bbe41dd07f50071ee61f969b81a'
'6fbffe59b886195b92c9a55137cef83021c16593f49714acb20023633e3ebb19'
- 'd081f2ef8793544685aad35dea75a7e6264a2cb987ff3541e6377f4a3650a28b'
+ '709e2fddba3c1f2ed4deb3a239fc0479bfa50c46e054e7f32db4fb1365fed070'
'771292942c0901092a402cc60ee883877a99fb804cb54d568c8c6c94565a48e1')
# Possible replacements are listed in build/linux/unbundle/replace_gn_files.py
# Keys are the names in the above script; values are the dependencies in Arch
@@ -107,14 +106,9 @@ prepare() {
# Fix vaapi linkage error
patch -Np1 -i ../fix-vaapi-ozone-build.patch
- # Missing include in third_party/blink/public/platform/web_rtc_rtp_source.h
- patch -Np1 -i ../add-missing-include-for-unique_ptr.patch
-
- # https://crbug.com/957519#c23
- patch -Np1 -i ../dns_util-make-DohUpgradeEntry-non-const.patch
-
- # https://crbug.com/1005244
- patch -Np1 -i ../fix-shutdown-crash-in-ProfileManager.patch
+ # https://crbug.com/819294
+ patch -Np1 -i ../launch_manager.h-uses-std-vector.patch
+ patch -Np1 -i ../include-algorithm-to-use-std-lower_bound.patch
# https://crbug.com/1014272
patch -Np1 -i ../icu65.patch
@@ -122,18 +116,20 @@ prepare() {
# Fixes from Gentoo
patch -Np1 -i ../chromium-system-icu.patch
patch -Np1 -i ../chromium-system-zlib.patch
+ patch -Np1 -i ../chromium-system-hb.patch
# https://crbug.com/1005508
patch -Np1 -i ../fix-spammy-unique-font-matching-log.patch
- # Load Widevine CDM if available
- #patch -Np1 -i ../chromium-widevine.patch
+ # Load bundled Widevine CDM if available (see chromium-widevine in the AUR)
+ # M79 is supposed to download it as a component but it doesn't seem to work
+ patch -Np1 -i ../chromium-widevine.patch
# https://crbug.com/skia/6663#c10
patch -Np0 -i ../chromium-skia-harmony.patch
# Ungoogled chromium stuff
- _ungoogled_repo="$srcdir/$_pkgname-master"
+ _ungoogled_repo="$srcdir/$_pkgname"
_utils="${_ungoogled_repo}/utils"
msg2 'Applying ungoogled chromium patches'
# Prune binaries
@@ -182,14 +178,18 @@ build() {
export NM=nm
# Ungoogled Chromium stuff
- _ungoogled_repo="$srcdir/$_pkgname-master"
+ _ungoogled_repo="$srcdir/$_pkgname"
nproc=$(nproc)
mkdir -p out/Release
# Assemble GN flags
cp "$_ungoogled_repo/flags.gn" "out/Release/args.gn"
printf '\n' >> "out/Release/args.gn"
cat "$srcdir/flags.archlinux.gn" >> "out/Release/args.gn"
-
+
+ if [[ -n ${_system_libs[icu]+set} ]]; then
+ _flags+=('icu_use_data_file=false')
+ fi
+
if check_option strip y; then
_flags+=('symbol_level=0')
fi