summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 11f8843f45f7..65fb0ea456ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=ungoogled-chromium-xdg
-pkgver=101.0.4951.54
+pkgver=101.0.4951.64
pkgrel=1
_launcher_ver=8
_gcc_patchset=4
@@ -31,6 +31,8 @@ options=('debug' '!lto') # Chromium adds its own flags for ThinLTO
source=(https://commondatastorage.googleapis.com/chromium-browser-official/chromium-$pkgver.tar.xz
https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver/chromium-launcher-$_launcher_ver.tar.gz
https://github.com/stha09/chromium-patches/releases/download/chromium-${pkgver%%.*}-patchset-$_gcc_patchset/chromium-${pkgver%%.*}-patchset-$_gcc_patchset.tar.xz
+ fix-no-member-named-tie-in-namespace-std.patch
+ iwyu-add-utility-for-std-exchange.patch
enable-GlobalMediaControlsCastStartStop.patch
chromium-libxml-unbundle.patch
sql-make-VirtualCursor-standard-layout-type.patch
@@ -38,9 +40,11 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/chrom
xdg-basedir.patch
no-omnibox-suggestion-autocomplete.patch
index.html)
-sha256sums=('c26cc6fd453d9a42a6b5e46fa4f3ee62ed368bb78101512b6816bc5d8f4200b5'
+sha256sums=('9c5896e4135563453ac10d15698c18ef61eb5535dc611325b230ece4c5a8d8f7'
'213e50f48b67feb4441078d50b0fd431df34323be15be97c55302d3fdac4483a'
'8ed519d21ccd8b382ddd384e9c15306a60d2e3495f48a62dea07c9be9bbffebd'
+ '7ad0106161bbf25e2e603ae1a723ae4217155ebb26eb4778363ad396e8c14156'
+ '6f666ef0acb08704ca58cc0d5e97e7ce64d8fea51042e593adae1ce15a61231c'
'779fb13f2494209d3a7f1f23a823e59b9dded601866d3ab095937a1a04e19ac6'
'fd3bf124aacc45f2d0a4f1dd86303fa7f2a3d4f4eeaf33854631d6cb39e12485'
'b94b2e88f63cfb7087486508b8139599c89f96d7a4181c61fec4b4e250ca327a'
@@ -58,7 +62,7 @@ source=(${source[@]}
ozone-add-va-api-support-to-wayland.patch
wayland-egl.patch)
sha256sums=(${sha256sums[@]}
- '8c5da085191a8586bf52ff3bbd0548f1af0fe1792c5db8530d4b158df83a092b'
+ 'eb70d0260f121faa6e2efd8e80a5e258f23474a214ff9f4f112bdcffdaaadd83'
'babda4f5c1179825797496898d77334ac067149cac03d797ab27ac69671a7feb'
'07bdc1b3fc8f0d0a4804d111c46ce3343cd7824de562f2848d429b917ce4bcfd'
'34d08ea93cb4762cb33c7cffe931358008af32265fc720f2762f0179c3973574')
@@ -109,6 +113,8 @@ prepare() {
patch -Np1 -i ../use-oauth2-client-switches-as-default.patch
# Upstream fixes
+ patch -Np1 -i ../fix-no-member-named-tie-in-namespace-std.patch
+ patch -Np1 -i ../iwyu-add-utility-for-std-exchange.patch
# Revert kGlobalMediaControlsCastStartStop enabled by default
# https://crbug.com/1314342
patch -Rp1 -F3 -i ../enable-GlobalMediaControlsCastStartStop.patch