summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e20af037d233..6e64182df17a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -186,8 +186,9 @@ build() {
_ungoogled_repo="$srcdir/$_pkgname-$_uc_ver"
readarray -t -O ${#_flags[@]} _flags < "${_ungoogled_repo}/flags.gn"
- # -fcf-protection breaks some third_party libraries
+ # remove flags the break building
CFLAGS=${CFLAGS/-fcf-protection}
+ CFLAGS=${CFLAGS/-fexceptions}
CXXFLAGS="$CFLAGS"
# Facilitate deterministic builds (taken from build/config/compiler/BUILD.gn)