summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 12 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 82b94d55989c..dfd604bf7814 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@
# binary version of this package (-bin): github.com/noahvogt/ungoogled-chromium-xdg-bin-aur
pkgname=ungoogled-chromium-xdg
-pkgver=124.0.6367.60
+pkgver=124.0.6367.78
pkgrel=1
_launcher_ver=8
_manual_clone=0
@@ -23,10 +23,9 @@ depends=('gtk3' 'nss' 'alsa-lib' 'xdg-utils' 'libxss' 'libcups' 'libgcrypt'
'ttf-liberation' 'systemd' 'dbus' 'libpulse' 'pciutils' 'libva'
'libffi' 'desktop-file-utils' 'hicolor-icon-theme')
makedepends=('python' 'gn' 'ninja' 'clang' 'lld' 'gperf' 'nodejs' 'pipewire'
- 'rust' 'qt5-base' 'java-runtime-headless' 'git')
+ 'rust' 'qt5-base' 'qt6-base' 'java-runtime-headless' 'git')
optdepends=('pipewire: WebRTC desktop sharing under Wayland'
'kdialog: support for native dialogs in Plasma'
- 'qt5-base: enable Qt5 with --enable-features=AllowQt'
'gtk4: for --gtk-version=4 (GTK4 IME might work better on Wayland)'
'org.freedesktop.secrets: password storage backend on GNOME / Xfce'
'kwallet5: support for storing passwords in KWallet on Plasma')
@@ -36,12 +35,14 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/chrom
https://gitlab.com/Matt.Jolly/chromium-patches/-/archive/${pkgver%%.*}/chromium-patches-${pkgver%%.*}.tar.bz2
drop-flag-unsupported-by-clang17.patch
compiler-rt-adjust-paths.patch
+ qt-6.7.patch
use-oauth2-client-switches-as-default.patch)
-sha256sums=('ebd553527149cb8477a522df90acd6cea2388a6f431e2db589a0301df1d0cae2'
+sha256sums=('697ea9e8591e0a74deea260a50441711b1ea499ca19e91d6012c5b4d200d1acf'
'213e50f48b67feb4441078d50b0fd431df34323be15be97c55302d3fdac4483a'
'c2bc4e65ed2a4e23528dd10d5c15bf99f880b7bbb789cc720d451b78098a7e12'
'3bd35dab1ded5d9e1befa10d5c6c4555fe0a76d909fb724ac57d0bf10cb666c1'
'b3de01b7df227478687d7517f61a777450dca765756002c80c4915f271e2d961'
+ 'e30623f36c54f4af3a8aa7d9400f7d2bed6ef560f15d665d2aa8fd777cb2565f'
'e393174d7695d0bafed69e868c5fbfecf07aa6969f3b64596d0bae8b067e1711')
# ungoogled-chromium-xdg patches
@@ -76,7 +77,7 @@ source=(${source[@]}
0001-ozone-wayland-implement-text_input_manager_v3.patch
0001-ozone-wayland-implement-text_input_manager-fixes.patch)
sha256sums=(${sha256sums[@]}
- '22899b0817ccf459ad7f4c0742bea0a0911eee2e7e4d140cd8cff30e51d66bbd'
+ '8dabdfa54e0293790d6299aff28aaeb25d61359b0f99321ddd20df9031877c5b'
'8ba5c67b7eb6cacd2dbbc29e6766169f0fca3bbb07779b1a0a76c913f17d343f'
'2a44756404e13c97d000cc0d859604d6848163998ea2f838b3b9bb2c840967e3'
'd9974ddb50777be428fd0fa1e01ffe4b587065ba6adefea33678e1b3e25d1285'
@@ -152,6 +153,9 @@ prepare() {
# Allow libclang_rt.builtins from compiler-rt >= 16 to be used
patch -Np1 -i ../compiler-rt-adjust-paths.patch
+ # Fix build with Qt 6.7
+ patch -Np1 -i ../qt-6.7.patch
+
# Fixes for building with libstdc++ instead of libc++
patch -Np1 -i ../chromium-patches-*/chromium-117-material-color-include.patch
@@ -263,6 +267,8 @@ build() {
'enable_hangout_services_extension=true'
'enable_widevine=true'
'enable_nacl=false'
+ 'use_qt6=true'
+ 'moc_qt6_path="/usr/lib/qt6"'
"google_api_key=\"$_google_api_key\""
)
@@ -364,6 +370,7 @@ package() {
chrome_200_percent.pak
chrome_crashpad_handler
libqt5_shim.so
+ libqt6_shim.so
resources.pak
v8_context_snapshot.bin