summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cce12e41f0c6..d847fb5576c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,16 @@
pkgname=unicodemoticon
pkgver=2.3.4
-pkgrel=1
+pkgrel=2
pkgdesc="Like a Color Picker but for Unicode Emoticons. Trayicon with Unicode Emoticons using Python3 Qt5."
url="https://github.com/juancarlospaco/unicodemoticon"
depends=('python' 'python-pyqt5' 'python-anglerfish')
-optdepends=('ttf-symbola: Font with emoji')
+optdepends=(
+ 'ttf-symbola: Font with emoji'
+ 'noto-fonts-emoji: Another font with emoji'
+ 'noto-fonts: Fonts designed to cover a wide unicode range'
+ 'ttf-freefont: Another font covering a wide unicode range'
+ 'ttf-ancient-fonts: Contains ttf-symbola and yet more fonts covering a wide unicode range'
+)
makedepends=('python-distribute')
license=('GPL')
arch=('any')
@@ -15,8 +21,6 @@ md5sums=('97caf0797231077eec7bbb8c58957a63')
build() {
cd "$srcdir/$pkgname-$pkgver"
python setup.py build
-
- python -c 'import unicodemoticon; print(unicodemoticon.AUTOSTART_DESKTOP_FILE)' > unicodemoticon.desktop
}
@@ -24,5 +28,5 @@ package() {
cd "$srcdir/$pkgname-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1
- install -Dm755 unicodemoticon.desktop "$pkgdir/usr/share/applications/unicodemoticon.desktop"
+ install -Dm755 unicodemoticon/unicodemoticon.desktop "$pkgdir/usr/share/applications/unicodemoticon.desktop"
}