summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9fa343555708
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Paul Fauchon <p.fauchon at gmail dot com>
+pkgname=unifi-throughput-ncurses
+pkgver=r57.b7c113f
+pkgrel=1
+pkgdesc="Display unifi controller throughput in a terminal"
+arch=('x86_64')
+url="https://github.com/lamarios/unifi-throughput-ncurses/"
+license=('MIT')
+depends=('ncurses')
+makedepends=('git' 'go')
+
+source=("git://github.com/lamarios/unifi-throughput-ncurses/")
+
+sha512sums=('SKIP')
+
+pkgver() {
+ cd unifi-throughput-ncurses
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd unifi-throughput-ncurses
+ make
+ mkdir -p $pkgdir/usr/bin
+ cp unifi-throughput $pkgdir/usr/bin/unifi-throughput
+}
+