summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ef5db05e1d13..4fac67162c24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,12 +13,14 @@ install=unifi-video.install
source=("http://dl.ubnt.com/firmwares/unifi-video/${pkgver}/unifi-video_${pkgver}~Ubuntu16.04_amd64.deb"
'unifi-video.service'
'unifi-video.sysusers'
- 'unifi-video.patch')
+ 'unifi-video.patch'
+ 'server.xml.patch')
sha256sums=('2e37248acf0ca15fb864ce71081c22b9ff323414163acc9039da5417c42d1cc9'
'9df948b046347c25e7c83e4837284ef63d9f8d3f28daa20a6c36e203e3ebfdb3'
'90fb2f826a70d3b7815cd6a2253c2af6754c17504be28ef92ee223bd02093730'
- '903c8def2668124570986f113fabf7ef03a1c94cde3a42dbf530ad6a19f139e7')
+ '903c8def2668124570986f113fabf7ef03a1c94cde3a42dbf530ad6a19f139e7'
+ '0636452a8e45a64f0adf108afbb5823921fb013b427eaf644d9bae0d97c27b93')
check() {
if ! [[ -x $( which java ) ]]; then
@@ -44,6 +46,10 @@ package() {
cd "${pkgdir}/usr/bin"
patch -N < "${srcdir}/unifi-video.patch"
+ msg2 "Patching off compression..."
+ cd "${pkgdir}/usr/lib/unifi-video/conf"
+ patch -N < "${srcdir}/server.xml.patch"
+
msg2 "Installing systemd files..."
install -D -m 644 "${srcdir}/unifi-video.service" "${pkgdir}/usr/lib/systemd/system/unifi-video.service"
install -D -m 644 "${srcdir}/unifi-video.sysusers" "${pkgdir}/usr/lib/sysusers.d/unifi-video.conf"