summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1d80f79c1d71..7375d9d44092 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=unifi-video
pkgver=3.6.0
-pkgrel=3
+pkgrel=4
pkgdesc="Centralized management system for Ubiquiti UniFi Surveillance Cameras"
arch=('x86_64')
url="https://www.ubnt.com/"
license=('custom')
-depends=('mongodb' 'jre8-openjdk-headless' 'java-jsvc' 'lsb-release')
+depends=('mongodb' 'java-runtime' 'java-jsvc' 'lsb-release')
conflicts=('unifi-video-beta')
install=unifi-video.install
source=("http://dl.ubnt.com/firmwares/unifi-video/${pkgver}/unifi-video_${pkgver}~Ubuntu16.04_amd64.deb"
@@ -18,7 +18,14 @@ source=("http://dl.ubnt.com/firmwares/unifi-video/${pkgver}/unifi-video_${pkgver
sha256sums=('1c2963fd4071e0f25649c37b833fbaa41f36e51138a6e4eec9228e4737c731bd'
'9df948b046347c25e7c83e4837284ef63d9f8d3f28daa20a6c36e203e3ebfdb3'
'90fb2f826a70d3b7815cd6a2253c2af6754c17504be28ef92ee223bd02093730'
- '87f685b8f43a0cf3c03297aa29b7db5a7536f1e245b792370b2b625689d6c69b')
+ '903c8def2668124570986f113fabf7ef03a1c94cde3a42dbf530ad6a19f139e7')
+
+check() {
+ if ! [[ -x $( which java ) ]]; then
+ msg2 "Could not find java, please use archlinux-java to select a default."
+ exit 1
+ fi
+}
package() {
msg2 "Extracting unifi-video..."