summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 2 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0f9027c206ab..0e217e42e119 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=unigine-superposition
_pkgname=Unigine_Superposition
pkgver=1.1
-pkgrel=3
+pkgrel=4
pkgdesc="Interactive Unigine Benchmark: walk through a lab of a lone professor"
arch=('x86_64')
url="https://benchmark.unigine.com/superposition"
@@ -27,12 +27,10 @@ depends=(
'libxrandr'
'libxrender'
'libx11'
- 'openal'
'qt5-base'
'sh'
'zlib'
)
-makedepends=('patchelf')
options=('!strip')
_tarname="${_pkgname}-${pkgver}.run"
source=("${_tarname}::https://assets.unigine.com/d/${_tarname}" "Superposition.desktop")
@@ -50,7 +48,7 @@ build() {
cat >> "${srcdir}/bin/unigine-superposition" << \here
#!/bin/sh
cd /opt/unigine-superposition/bin
-LD_LIBRARY_PATH='/opt/unigine-superposition/bin:/opt/unigine-superposition/bin/qt/lib' ./launcher
+./launcher
here
}
@@ -72,12 +70,6 @@ package() {
# remove unneeded install scripts
rm -v "${pkgdir}/opt/${pkgname}/"*install.sh
- # removing unneded libraries
- rm -v "${pkgdir}/opt/${pkgname}/bin/libopenal.so"
-
- # removing runpaths
- patchelf --remove-rpath "${pkgdir}/opt/${pkgname}/bin/launcher"
-
# misc
install -v -Dm644 docs/Superposition_Benchmark_End-User_License_Agreement.pdf "${pkgdir}"/usr/share/licenses/${pkgname}/license
install -v -Dm644 docs/Superposition_Benchmark_User_Manual.pdf "${pkgdir}"/usr/share/doc/${pkgname}/User_Manual.pdf