summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD65
1 files changed, 15 insertions, 50 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c4f537936a4b..62087e92559c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,13 @@
# Maintainer: Oscar Morante <spacepluk at gmail dot com>
-_version=2018.2.0
-_build=f1
-_buildtag=20180709
-_randomstring=db9a69dc5569
+_version=2018.3.0
+_build=b1
+_randomstring=3f0ac31c6d6f
_prefix=/opt/UnityBeta
-_unitydownloads="http://beta.unity3d.com/download/${_randomstring}"
-#_keepdownloads=yes
pkgname=unity-editor-beta
pkgver=${_version}${_build}+${_buildtag}
-pkgrel=2
+pkgrel=1
pkgdesc="The world's most popular development platform for creating 2D and 3D multiplatform games and interactive experiences."
arch=('x86_64')
url='https://unity3d.com/'
@@ -30,61 +27,29 @@ depends=('desktop-file-utils'
'intel-tbb'
'gtk3')
optdepends=('unity-editor-beta-doc'
- 'unity-editor-beta-standardassets'
- 'unity-editor-beta-example'
'unity-editor-beta-android'
'unity-editor-beta-ios'
'unity-editor-beta-mac'
'unity-editor-beta-webgl'
'unity-editor-beta-windows'
- 'unity-editor-beta-facebook')
-makedepends=('gtk2' 'libsoup' 'libarchive')
-source=("${_unitydownloads}/UnitySetup-${_version}${_build}"
+ 'unity-editor-beta-facebook'
+ 'visual-studio-code-bin')
+source=("https://beta.unity3d.com/download/${_randomstring}/LinuxEditorInstaller/Unity.tar.xz"
'unity-editor-beta'
'unity-editor-beta.desktop'
- 'unity-editor-beta-icon.png')
-sha1sums=('25f558636adc41bc8263dc4976fd9df86d1f9f6d'
+ 'unity-editor-beta-icon.png'
+ 'eula.txt')
+sha1sums=('67984c80e142d244c35eefad9f737991b7541049'
'd61175685d0836a79b2d4582c09ea23ed5ee18e9'
'c348f141232ec06c6558fd42b5cbf86a75e2d02d'
- 'fddf4861974f88f0565de7f54f7418204e729894')
+ 'fddf4861974f88f0565de7f54f7418204e729894'
+ '1c3d4bc66fd16a10e68f78320e16cfd86afac7ac')
options=(!strip)
PKGEXT='.pkg.tar' # Prevent compressing of the final package
-unity-setup() {
- ./UnitySetup-${_version}${_build} \
- --download-location="${startdir}" \
- --install-location="${pkgdir}${_prefix}" \
- --unattended $@
-}
-
-extract-component() {
- msg2 "Extracting $1..."
- yes | unity-setup --components=$1 > "/tmp/$1.log"
-}
-
-prepare() {
- echo "************************************************************"
- echo "*** ***"
- echo "*** RIGHT NOW THE STABLE RELEASE IS NEWER! ***"
- echo "*** ***"
- echo "*** Edit this if you *really* want an old beta =] ***"
- echo "*** otherwise go and install unity-editor ***"
- echo "************************************************************"
- return 1
-
- chmod +x "${srcdir}/UnitySetup-${_version}${_build}"
-}
-
package() {
- msg2 "Extracting EULA..."
- echo n | unity-setup | head -n -2 > "${srcdir}/EULA"
-
- mkdir -p "${pkgdir}${_prefix}"
- extract-component Unity
-
- if [ -z "${_keepdownloads}" ]; then
- rm "${startdir}/Unity.tar.xz"
- fi
+ install -d "${pkgdir}/${_prefix}"
+ mv "${srcdir}/Editor" "${pkgdir}/${_prefix}"
# HACK: fixes WebGL builds by adding a symlink (python -> python2) to the PATH
ln -s /usr/bin/python2 "${pkgdir}${_prefix}/Editor/python"
@@ -98,6 +63,6 @@ package() {
install -Dm644 -t "${pkgdir}/usr/share/applications" "${srcdir}/unity-editor-beta.desktop"
install -Dm644 -t "${pkgdir}/usr/share/icons/hicolor/256x256/apps" "${srcdir}/unity-editor-beta-icon.png"
install -Dm755 -t "${pkgdir}/usr/bin" "${srcdir}/unity-editor-beta"
- install -Dm644 "${srcdir}/EULA" "${pkgdir}/usr/share/licenses/${pkgname}/EULA"
+ install -Dm644 "${srcdir}/eula.txt" "${pkgdir}/usr/share/licenses/${pkgname}/eula.txt"
}