summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 11 insertions, 32 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 242ac106493b..4abb4d83ff9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,9 @@
# Maintainer: Oscar Morante <spacepluk at gmail dot com>
-_version=2018.2.0
-_build=f1
-_buildtag=20180709
-_randomstring=db9a69dc5569
+_version=2018.3.0
+_build=b1
+_randomstring=3f0ac31c6d6f
_prefix=/opt/UnityBeta
-_unitydownloads="http://beta.unity3d.com/download/${_randomstring}"
-#_keepdownloads=yes
pkgname=unity-editor-beta-windows
pkgver=${_version}${_build}+${_buildtag}
@@ -16,34 +13,16 @@ arch=('x86_64')
url='https://unity3d.com/'
license=('custom')
depends=('unity-editor-beta')
-makedepends=('gtk3' 'libsoup' 'libarchive')
-source=("${_unitydownloads}/UnitySetup-${_version}${_build}")
-sha1sums=('25f558636adc41bc8263dc4976fd9df86d1f9f6d')
+makedepends=('cpio')
+source=("https://beta.unity3d.com/download/${_randomstring}/MacEditorTargetInstaller/UnitySetup-Windows-Mono-Support-for-Editor-${_version}${_build}.pkg")
+sha1sums=('304fedca8da8f525f31402eaeefdc6d6c6a42e89')
options=(!strip)
PKGEXT='.pkg.tar' # Prevent compressing of the final package
-unity-setup() {
- ./UnitySetup-${_version}${_build} \
- --download-location="${startdir}" \
- --install-location="${pkgdir}${_prefix}" \
- --unattended $@
-}
-
-extract-component() {
- msg2 "Extracting $1..."
- yes | unity-setup --components=$1 > "/tmp/$1.log"
-}
-
-prepare() {
- chmod +x "${srcdir}/UnitySetup-${_version}${_build}"
-}
-
-package_unity-editor-beta-windows() {
- mkdir -p "${pkgdir}${_prefix}"
- extract-component Windows-Mono
-
- if [ -z "${_keepdownloads}" ]; then
- rm "${startdir}/UnitySetup-Windows-Mono-Support-for-Editor-${_version}${_build}.pkg"
- fi
+package() {
+ _dest="${pkgdir}/${_prefix}/Editor/Data/PlaybackEngines/WindowsStandaloneSupport"
+ install -d "${_dest}"
+ cd "${_dest}"
+ cat "${srcdir}/TargetSupport.pkg.tmp/Payload" | gzip -dc | cpio -i
}