summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 9 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 76e3ef62bd69..ac2a3054d7b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=unity-editor-bin
pkgver=5.1.0f3+2015082501
-pkgrel=1
+pkgrel=2
pkgdesc="The world's most popular development platform for creating 2D and 3D multiplatform games and interactive experiences"
arch=('x86_64')
license=('custom')
@@ -19,10 +19,8 @@ provides=('unity-editor')
conflicts=('unity-editor')
options=(!strip)
install=${pkgname}.install
-source=("https://unity3d.com/legal/eula"
- "http://download.unity3d.com/download_unity/unity-editor-${pkgver}_amd64.deb")
-md5sums=('0a8c7805f91c1cd46de5bdfba683eeb4'
- 'c1c559bb684d00369ee6710be01c3700')
+source=("http://download.unity3d.com/download_unity/unity-editor-${pkgver}_amd64.deb")
+md5sums=('c1c559bb684d00369ee6710be01c3700')
# Prevent compression of the final package since it would take too long (sereausly!)
PKGEXT='.pkg.tar'
@@ -38,12 +36,12 @@ package() {
chown root:root "${pkgdir}"/opt/Unity/Editor/chrome-sandbox
chmod 4755 "${pkgdir}"/opt/Unity/Editor/chrome-sandbox
- # Linking binaries
+ # Linking executables
mkdir -p "${pkgdir}"/usr/bin
- echo -e "#!/bin/sh\nexec /opt/Unity/Editor/Unity \"$@\"" > "${pkgdir}"/usr/bin/unity-editor
- echo -e "#!/bin/sh\nexec /opt/Unity/MonoDevelop/bin/monodevelop \"$@\"" > "${pkgdir}"/usr/bin/unity-monodevelop
- chmod 755 "${pkgdir}"/usr/bin/unity-editor "${pkgdir}"/usr/bin/unity-monodevelop
+ ln -s /opt/Unity/Editor/Unity "${pkgdir}"/usr/bin/unity-editor
+ ln -s /opt/Unity/MonoDevelop/bin/monodevelop "${pkgdir}"/usr/bin/unity-monodevelop
- # Moving the license in place
- install -Dm644 "${srcdir}/eula" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ # Refering to the online license
+ mkdir -p "${pkgdir}"/usr/share/licenses/${pkgname}
+ echo "Please refer to https://unity3d.com/legal/eula for detailed license information." > "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
}